Does the OT support incoming relative CC?

this is correct.
LD2 allows for this kind of grouped mapping as well.
you will run into problems as soon as you try to map anything more complex. (like 3 band eqs on different MIDI channels, mutliple fx parameters, etc.)
with FFs you will need some kind of CC remapping, as OT still does not do that for incoming CCs.

Doepfers, on the other hand, can be flashed with sysex. well done, doepfer.

do you have iOS (*android might work too) and a midi interface? i have a LD2 remapper for OT.

do you have iOS (*android might work too) and a midi interface? i have a LD2 remapper for OT.[/quote]
That’s intriguing. Is that using TouchOsc or something ?

I’m confused here. I just bought a controller and this does not actually work in my experience. When my controller is set to relative mode (Behringer X touch mini) the OT reacts to the precise CC value versus correctly interpreting is as an increase/decrease value.
Relative modes seem to be based on cc values still, for example the mode I’m using using value 63 for negative and 65 for positive. Unfortunately OT only sees the value of 63 and 65 and not increase/decrease. You said above that relative input does work. Am I missing something?

1 Like

I experienced the same problem with my faderfox EC4 which send 63/65 in relative mode. The ot jumps to 63/65 but doesn’t understand the relative increase or decrease.
I did not investigate that much, if someone knows more about it, I’ll be happy to know how to solve that.

You can send cc#61 to dump cc values to your controller. From there you can use relative mode.


To clarify things:

The OT does NOT support relative CCs so using relative mode will not work. The OT always expects absolute CCs values.

To get the controller in sync with the OT you first need to send CC#61 (Send request, 0 = all audio CC) to the OT and the OT will respond with CC messages of all its internal CC parameters. A controller like the EC4 can then sync itself to these values.


Well dang… I have been trying to make a “control all” style setup similar to the DN/DT. I’m not licked yet but this is another big set back.

I’m trying to send CC#61 but I cannot get the answer back from the OT.
I change the volume of the track on the OT (so the faderfox doesn’t reflect the actual value anymore) and I then send CC61 on track 1 or 9 (auto in my case) but it does not seems to work.
I have “audio CC out” set to int+ext on the OT and my midi cables are reliable.

What do I miss ?

I just got an Octa MKi and have a beat step pro I’m not using. Anybody know if it can receive OT cc values to sync up to in controller mode? I’m thinking it can’t…

Is there a MIDI track which shares the same MIDI channel as an audio track? Because when a MIDI track and an audio track shares a channel the audio track cannot send (while the MIDI track cannot receive).

Also make sure the auto channel isn’t used by a track.

Another guess: are you really sending the required value 0 for the CC#61?

Are both MIDI in and MIDI out connected correctly with the correct adapter cables?

1 Like

In my tests with FaderfoxEC4 the cc61 request worked on every channel set on MIDI>CHANNELS page.

Image below shows the example: sending cc61 on channel 1, 2, 3, 4, 5, 6, 10, 11 or 16 gave same results –
Faderfox was synced back, values reset.
I checked with one parameter (Balance) on T1 switching extreme values using two parts.


Would you mind sharing how you set up the EC4 ?
I have mine set up to CCAb (absolute), Chan to OT autochannel (but none of the others channels work), Numb 061, Lower 000 and Upper 127.
When knob is at 0, no sync at all.

As @tnussb suggested, I did check my OT midi configuration but no midi track is shared with the audio, and auto is not used by a track. Both midi are connected with 2 officials faderfox adaptater and both are working if I use them as midi OUT.

Does the Audio CC OUT need to be set to INT+EXT on the OT midi/control page ?

If you want a controller to reflect changes you make on OT, OT has to send these changes to the controller. So, yes.

1 Like

That’s what I thought and that’s what I did but still no sync.


In MIDI>CONTROL setup I have default settings:

In Faderfox I set lower and upper values at 000, so every time I turn encoder left or right the needed value (0) is sent:

On OT’s screen both pixels indicating incoming midi data and outcoming midi data are blinking when turning encoder=sending cc61, this is your visual feedback for midi:

1 Like

Thanks for your help ! I set everything as you said but it doesn’t work.
Damn !
I’ll write to faderfox and see if something else can be tried.

Ok, I spoke to fast.
It works for the audio track parameters like fx or amp, but not for the track level. Can anyone confirm ?

1 Like

Track level cc07 doesn’t work.
Track level cc46 works.

It is mentioned in the manual:


Bears are the paper tape I use.


Greeeat !
Thanks for your patience, it finally works !