DN/DT midi Out AND Thru


I use my KS as master,midi Out of KS,into Kenton thru 5…then into the DT,DN, A4MK2, SH-01,CRAVE…the rest of my synths are just daisy chained from the OUT of the crave into the IN of the Minilogue…etc etc.sometimes,I have to press SHIFT& KBD PLAY to hear whatever unit you want to play after changing midi Ch. On the KS.:+1:t2:

If I am reading the KS manual correctly (something perhaps you should have done) you can set the KS to act as midi thru. So you can go DT -> KS -> DN and press start in the DT to start DN and use keyboard to play DN notes.

If you want the keyboard to control the DT but not the DN, you could DT -> DN thru to KS out to DT. Then you can press play on DT and use keyboard On the DT I think.

Or you can DT out -> KS (midi as thru) -> DT (thru) -> DN. Then you can use keyboard to control both but can’t send anything from DT to DN. Actually. You might be able to still send stuff from DT to DN

No. If you use the AUTO CHANNEL configuration that was linked to in an earlier reply, you can do exactly what you want.

The only topic that was linked to here referred to using a midi splitter cable. Is that part not necessary you mean?

Neither a “MIDI splitter cable”, nor any hardware other than what you already have, is required to achieve what you want.


  • KS MIDI Out to DN MIDI In,
  • DN MIDI Out to DT MIDI In.

Set DN to send clock and transport and DT to receive both.

Set the KS’s MIDI channel to match the AUTO CHANNEL number on the DN. Now the KS will play whichever track is active on the DN.

Set the channel of one MIDI track on the DN to match the AUTO CHANNEL number of the DT. Now if you select that MIDI track on the DN then the KS will play whichever track is active on the DT.


I really appreciate your effort to explain this clearly, but for some reason it still doesn’t work. I’ve followed your steps precisely, I think.

The DN has the following channels set:

  • Track 1-4: midi ch 11-14
  • Midi track 1: midi ch 10
  • midi tracks 2-3: OFF
  • fx control ch: 15
  • auto channel: 16
  • output ch: trk ch

The DT:

  • Track 1-8: midi ch 1-8
  • midi tracks 1-8: OFF
  • fx control ch: 9
  • auto channel: 10

I set the KS to play on channel 10 and hit keys, no midi events ever reaches the DT. The DN’s Note screen does register the keystrokes however.

If I instead hit the trig keys in the DN “keyboard” itself, the DT sounds play.

If I switch the DN midi port from Out (Sync A) to Thru (Sync B), the behavior reverses: the DT now receives notes hit from the KS, but ignores notes hit on the built-in DN keyboard.

In other words, it’s still an either or. Are you really sure this is supposed to work the way you describe? I’m about to lose my hair.

Big thanks again for your help!

Oh, and reading what I wrote originally, I guess you’re technically right, because I only said I want to be able to play the DT via the KS. I thought it would be implied that I also intend to play the DN’s amazing FM synthesis tracks from the KS too.

So, to be clear, I want to play both the Digit***'s AND have their clocks synced without relying on the KS transport (because the KS transport activates its built-in arp or sequencer depending on the mode).

Maybe I can live with this limitation because hitting the Play buttons simultaneously on the Digis isn’t that hard during those moments when I want to jam live and find my way around a new song idea without being forced to use the arp.

This is your error.

You need to set the KS MIDI channel number to 16, matching the AUTO CHANNEL number of the DN so that the DN can direct the incoming MIDI messages to the active track on the DN.

If the active track on the DN is the first MIDI track on the DN, then the MIDI messages will be sent on to the DT. On the DT, the AUTO CHANNEL feature will direct those MIDI messages to the DT’s active track.

If you make this one change then the system should work as I described.


I tried that and it still doesn’t work. The DT plays the notes received when playing directly on the DN’s built-in keyboard/trig keys, but when playing in the KS on any channel but 11-14 (the assigned midi channels for the built-in tracks of the DN as per above), nothing happens on the DT.

I’ve went through basically all settings across the 3 Midi config sub pages of both the DN and DT to figure out if there’s anything else going on. I also tried different midi cables to rule out the unlikely case that the cable might be faulty.

Events from the KS simply will not make its way through the DN midi out port, only the midi through. Are you really sure about your claim that this is meant to work the way you describe? According to the manual, this is a limitation of the midi interface, where the out port passes midi notes from the machine itself, and the thru port passes midi notes that was received from the midi in port. The only reason why I’m still trying to get it to work is because you seem so sure it will work. :blush:

Bad news it’s probably human error on your part. A. Peter knows his shit. B. I reread his instructions and I don’t see how it could t work if the settings are right.

Reread his post and check up the manuals and try again. You’ll get there

1 Like

There are dozens of examples on the forum of this AUTO CHANNEL feature working as expected.

Let’s do some troubleshooting by breaking the process down step-by-step.

First, the KS and the DN:

Your posts indicate that you have tested your MIDI cables and connected KS MIDI Out to DN MIDI In.

You wrote that the AUTO CHANNEL number for the DN is set to 16. Therefore, ensure that you have set the MIDI channel number for the KS to 16.

The Auto Channel feature on the DN should direct the incoming MIDI messages to whichever track (synth or MIDI) on the DN is currently active (meaning it has the user interface focus).

The test for that is: if you select each of the DN’s four synth tracks in turn, do the keys of the KS play the sounds of each synth track in turn?

Try just that, and let us know how it goes.


Human error would be great because that means there’s a way. And it turns out there was! I’m mostly really grateful to @PeterHanes because he helped me not give up, but I also want to thank you @0mega for insisting I RTFM. I had actually already done it, but this time I read a little more and learned that there’s an error in the manual:

Page 68:

It turns out that this is incorrect. Setting the channel in the Midi Config menu does NOT also set the channel that this track sends to - you have to configure that manually as a second step.

Page 56 explains where this setting is changed:

It now works as I hoped it would. Big thanks for your help, both of you!


Your reading of the manual is not correct: the FX CHANNEL setting is for ingoing and outgoing MIDI messages related to the audio effects, not for the MIDI tracks.

But I’m glad that you were able to find the correct setting for the MIDI tracks, and hopefully you can now do everything that you wanted to do originally.


In case it’s some consolation, a lot of people trip over this, and the Func + push encoder is not very discoverable.


I erroneously highlighted the wrong line in the manual but look at this line instead:

This isn’t accurately describing how changing that setting works, because it doesn’t also set this setting. You have to manually set it using Func+pressing the knob in Syn1 to set it separately.

No wonder, since the manual is incorrect about this part!

In fact it’s correct, but you are misunderstanding it. The first sentence makes it clear that it’s related to the synth tracks, not the MIDI tracks. The second sentence, the one you underlined, describes what happens in response to turning the data entry knobs on those synth tracks.

But, again, the main thing is that you’ll be able to use your DN & DT to have fun making music. Have fun!

1 Like

100% agree on the main thing, and I appreciate the help a lot!

However, in order to not appear completely stupid (though ironically this may seal the deal), I again highlighted the wrong line in the manual. Look at the paragraph just below starting with “MIDI 1-4 CHANNEL”. This is the one I meant. It has the same sentence about it also setting the channel that the data entry knobs send. Though perhaps that is completely a separate thing still, related to which channel the actual knob movements transmit on and the actual note midi out is a different thing?

Anyway, suffice it to say that this was very non-obvious to me. Now, on to making music again. :joy:

Indeed, this relates to incoming MIDI control of the MIDI tracks (sentences 1 and 3), and I’m not sure about the second sentence. Maybe you can point this out on the dedicated topic for documentation:


1 Like