Digitone UI sluggish in Overbridge mode

That’s a good question. I would like to have an official statement about this, because this is something very crucial. But it seems that not all of us have this issue?

I have the same problem on my Digitone from time to time (Digitakt is fine). Starting a new project or reloading an old one seems to fix it for me.

1 Like

I have exactly the same problem. But I noticed that digitone starts to slow down when I use lp4 filter.

Same here.
Overbridge mode on, cable connected but no Oberbridge Digitone started, using the unit with headphones. And yes, happens mostly while tweaking the LP4 filter.

I bumped into this thread after once again being fed up with the ridiculous input lag. Sometimes the UI is a second or two behind the encoders, which makes any fine tuning impossible.

  • Windows 10
  • Digitone OS 1.31
  • Overbridge 2.0.58.8
  • no DAW or Overbridge Digitone window open

I read the last couple posts, and I noticed that all my tracks had LP4 filters set. However, since one of the tracks had the filter fully open, I just set it to OFF instead. Suddenly the massive sluggishness (while modulating any parameter on any track) disappeared. If I turned the filter back to LP4, things instantly became sluggish again.

Which track I disable the filter on seems to make a difference. At least in my case. Disabling track 4 and track 2 completely fixes it for me, but disabling the same LP4 filter on track 1 or 3 only somewhat alleviates the issue…

Another interesting thing to note is that the lag persists even after switching to a completely empty pattern. Then, changing the filter type for one particular track (track 3 in my case) completely resolves the problem for that pattern until I switch back to the original pattern. I don’t have to disable the filter, just switch the type, even switching back to the same filter type works.

1 Like

Below are steps that work for me to reproduce this issue in a fresh project and empty pattern.

Video: Digitone LP4 filter input delay

  • Windows 10

  • Digitone 1.31 (latest)

  • Overbridge 2.0.60.2 (latest)

  • No DAW open, no Overbridge Digitone app open

    In fact, you could even disable the entire Overbridge Engine in Windows. It makes no difference at all from what I can tell. Having the Overbridge driver installed is required, however.


  1. Close any DAW and the Overbridge Digitone app, if you have them open

  2. On the Digitone, create a new project (remember to save)

  3. Turn the device off and on again

    (These steps are all just to ensure there are no other factors contributing to the issue)

  4. Make sure the device is set to Overbridge mode in USB config, and plug the USB cable into your computer

  5. Start playback. While this is not strictly necessary, I think it makes the effect more pronounced

  6. Try modulating any parameter using the encoders (e.g. the filter cutoff), on any track, and notice that the response time is acceptable

  7. Go to the FLTR page of track 1 and change the filter mode to LP4

  8. Again, try modulating any parameter, on any track and observe that there is now a significant delay while using the encoders. The parameter will lag behind your inputs, making accurate modulation nearly impossible. If you make constant sweeping changes over a few seconds and then let go of the encoder, you’ll notice that the parameter keeps changing for quite some time

  9. Go to the FLTR page of track 1 and change the filter back to any other mode (e.g. LP2 or OFF)

  10. Try using the encoders and see that the input latency is back down to normal

  11. Repeat this process (step 5 and 6) but for tracks 2-4 instead. You will notice that the same global input latency strangely does not appear to happen for those tracks.

Bonus step:

  1. Enable LP4 for track 1 again, confirm that the encoders are sluggish and then try switching to a different (blank) pattern. Without touching the filters, notice that the encoders are still slow even though all the filters are now set to LP2. Change the track 1 filter type to any other value (you could even change it back to LP2) and observe that the input latency is gone again.

Hopefully, someone else is able to reproduce the issue by following these steps.

I’ve read a lot of threads where Elektron suggests that it’s related to automation, but this cannot be the case when reproducing using these steps. In fact, disabling the entire Overbridge Engine (which means there should be no communication) has no effect on the issue presented here. The only solution is disabling Overbridge mode, or unplugging the USB cable.

Please note I am not saying this is the only Overbridge issue causing latency on the Digitone. I know for a fact that too much automation from the DAW can cause similar issues, simply because the DT CPU is not powerful enough, but this one doesn’t really have a reasonable explanation.

(I also posted this on reddit: https://www.reddit.com/r/Elektron/comments/ourban/reproducing_digitone_overbridge_sluggishness/)

4 Likes

Nice, I’ll try these steps this weekend to see if it’s reproducible on my end. I haven’t used OB much at all since I made this topic.

Is this better with Overhub? Just curious never used OB

I cannot see how it would be, or at least why it would be, since this particular issue appears when using an LP4 filter on a specific track and not the others. It does not seem be related to USB hub bandwidth or anything like that.

I have the Overhub and the issue persists.
As people have said it is most definitely a software issue.
I have even made sure that my digitone keys is not recording automations in the preferences of ableton. It seems that as I introduce more info to it and make it work harder, only while it’s connected via overbridge, it just begins to do that laggy glitch where I will turn a knob like close the filter and it very slowly does the action a few seconds later. Big Bummer, and there’s been zero fixes for it…

BUT i have found a slight work around by just simply making it Audio+Midi over USB in the digitone settings instead of the overbridge mode. You won’t get to use overbridge on your computer but you’ll have your nice clean audio and it will all be in sync and not glitch!
Help us elektron!

That’s right its only whith LP4 filter, why ? So weird. I once saw a thread with Ess saying that in order to keep latency or CPU low there was an internal program reducing the UI speed when neceassary so it might be that the LP4 filter asks too much CPU or whatever ?

1 Like

Following your process I was able to duplicate and isolate the Digitone UI sluggishness while using Overbridge. Really hope they fix this because it makes performing songs on the Digitone with Overbridge unusable.

So was this ever dealt with? Anyone find solutions? I guess not. Started getting this issue more and worse now.

1 Like

I also have this issue. Seems that it’s only track 1 with the LP4 filter that makes everything all laggy to the point of not being usable. So looks like I’m avoiding using that filter on track 1, pretty annoying. Is this fixable by Elektron?

I got a reply from Elektron saying they’re aware of the problem and working on a fix.
They said it was related to LP4 filter but I get it when not even in LP4 mode. I also have no lag at all sometimes
It seems random.
What they actually said was they hope to have a fix in a future OS update.

2 Likes

just came across this issue.
how fokkin awful…
hope it´s beeing addressed asap!

2 Likes

So I mailed Elektron and this was the reply:

“We are aware that the Digitone Keys graphical user interface can become sluggish when using Overbridge, especially when the LP4 filter is assigned to one or multiple tracks as this filter is very heavy CPU-wise. As Overbridge is also taxing for the CPU, it can be too much in some cases. We hope to be able to address this for a future OS. I’m very sorry for the inconvenience.”

I tried a pattern with no LP4 filter making no difference.

As the first post in this thread is nearly two years old I do not have too much hope that this issue is going to be solved sadly ;(

5 Likes

In other words;
“Our Digitone CPU is not powerful enough to handle all the extra stuff we’ve thrown at the Digitone.
We might fix it if we feel like it………one day………maybe”