Digitone & iPad midi configuration

Hi all,
I’m having an issue that I haven’t been able to solve by reading through other threads on this topic.

I have hooked up the Digitone and iPad Air 2 with a camera connection kit & USB cable.

The Digitone can receive midi & clock from iPad. But it can’t send midi clock, midi notes, nothing.

Things to note before we look at the obvious answers.

  • I have the Digitone set to USB - Midi (not overbridge mode)
  • I’m definitely not having the issue others have had where my midi tracks are muted. - I have worked with the Digitone and other elektron boxes for years and have a good handle on midi track & mute settings.
    -I have ensured that all midi data from Digitone is also sending externally (not just internally)

I’m using either AUM or Audiobus. To be honest I’d be happy if I could get either to work.

Currently all I can achieve is sending clock from audiobus to Digitone which is working well - gotta appreciate the little wins!

Does anyone know of any iPad apps I can use to check/ monitor if any midi data is coming into iPad from Digitone? I want to rule out that it’s not just audiobus or aum config settings.

It’s running on one of the latest OS updates but I’m going to check if there are any more recent updates.

Let me know if you can think of any obvious settings I may be missing!


Whee are you trying to receive midi on the iPad? Each app should have its own midi settings.

If you want to sync with the digitone’s midi clock and start/stop, try AudioBus.

Hi, thanks for your quick reply, apologies, I hit post accidentally before I was done typing. I’ve got audiobus and I’ve synced them up all good. It is only working iPad to Digitone though. I would like to send midi data in the other direction to control synths with the Digitones midi channels.

As you say I have checked a lot of the iOS synths midi settings but still no luck. The Digitone shows up fine as a midi input device, but I can’t actually send any midi data.

There’s a Digitone setting to send/receive midi over MIDI, or USB, or both. Maybe it’s just set to MIDI?

Yeah, I’m pretty sure I’ve tried this, but I’ll double check that I haven’t unknowingly changed this to MIDI

Awesome, thanks for your help! I will check this out and report back

hmmm, this is strange. I used a midi monitor app. Initially the midi notes were coming through. Managed to successfully direct that midi to the iM1 app via audiobus.
-5 or 6 notes made it through with heaps of latency and then it glitched out and the midi monitor stopped picking up any incoming midi signals.

It’s making me think I’ve done everything correct but the Camera Connection Kit is malfunctioning. Are there different CCKs? USB2 vs USB3? etc.

If anyone has purchased a CCK that works perfectly, I would love a link!!!

The Apple Camera Connection Kit seems to be the only one that always works. Have you tried rebooting the iPad? Or try a different usb cable?