Digitone / Digitone Keys: bug reports

I’ve encountered arp-related crashing bug a few times. Thankfully not onstage, but I am nervous about that happening. I think I’ve found a way to avoid it, which is to not have more than one track using an arp. You could give that a try until they fix the bug.

1 Like

It took some investigation yes :joy: and yes, it can happen with simpler patterns as well, although usually this doesn’t crash the machine it just plays the programmed sequence wrong. I haven’t been able to pinpoint exactly what the cause is but it al revolves around the arp, voice allocation and sound locks (that have the arp enabled).
Some are easier to replicate than others, but for instance bug 3 is easy to replicate, and clearly not the intended behavior. I was kinda surprised that nobody (including myself) had noticed/reported it before.

Yes for instance if you soundlock sounds with the arp activated on T1, this will affect the arp on T2 while voice stealing is off. This shouldn’t happen. See bug 2

@Kraus @Looper I’m 98% sure your safe as long as you don’t combine it with massive sound locking. I don’t recall ever having a problem with every track running an arp while not sound locking the arp as well. Might want to confirm that before you rely on it live though :smirk: it’s been almost a year since I looked into this.


Thanks, yeah, I try and only use 2 max arps now and it mostly doesn’t happen - still a bit hairy though.


Ah, interesting, thanks for this info and all your effort looking into this.

I usually use the Digitone as a standalone groovebox and use sound locked arps nearly all the time to help make up for the lack of tracks. I’ve had this crash happen when just using two tracks, one with a sound locked arp and the other standard arp. Didn’t occur to me that the sound-locked one could be causing the issue. Have Elektron confirmed this bug?

Think I’m going to stop using sound-locked arps until a fix happens - maybe investigate using midi-loopback instead but have found that a bit glitchy when I’ve tried it before.


When I am controlling a midi channel via Logic through the DT that isn’t 1-4 it will definitely bug out! I am using it as an audio interface as well as a midi interface.

Also the LFO DEST menu can be pretty wonky under certain circumstances, it seems to do it the most when I’m trying to make changes during playback.

1 Like

From Elektron support:

I also suspect that the freeze could be related to the arpeggiator. As mentioned earlier, we have for a while been hunting a known bug that can cause a freeze, that we know is related to the arpeggiator. We have unfortunately not yet found the culprit, even though our developers have spent a lot of time investigating. We have not received many reports so it seems rare that users experience this bug, but we take it very seriously and I hope we can find a solution soon.

It goes to show not many people report the bugs.


But the problem is broader than the freezing, there is quite a few scenarios (which most user will find themselves in at least at some point) in which it simply doesn’t play back the proper sequence, it’s just that that is easier to not notice, or to falsely attribute to user-error, than a high pitched freezing buzz-kill.

Totally understandable btw I blamed it on user-error (myself) as well when I first noticed it. :meh:

Ugh I always assume plenty of people submit bug reports, so I haven’t bothered… I really should send one for this arp bug

1 Like

We all do :slight_smile:


Maybe a good practice would be to report at Elektron then complain here with the satisfaction of the duty being done. We should actually call the thread bug complaints instead of bug reports.


Good practice imo is to complain here, see if other people can reproduce/identify it as user error, then report to support.


Anyone got this error? OS1.32A

1 Like

So it has a lot of high end on that sound because you added a lot of err? (har har har)

Hope a power cycle can fix it.

Since I upgraded to 1.32 (then 1.32A), I’ve had two instances of entire projects being corrupted. In the first case, a different project ended up overriding an existing project. No idea how that happened. Then, today, using 1.32A, a backup of the same project became corrupted. The sound pool disappeared, there were suddenly only about 50 of the original 128 patterns.

Prior to 1.32 and 1.32A, I never had anything of this seriousness happen. Sorry I can’t provide any other information.

People, backup your work!!!

Yep only since 1.32A but consistenly, on different patches. If i turn the knob a value appears but after a while it goes back to Error.

1 Like

Are you using MIDI or overbridge to control the Digitone?
I’ve seen this before when the messages sent are out of range; the 'tone shows ERR, mainly on the B operator, if I recall.

On the mixer/Master Overdrive page, FUNC+NO doesn’t revert the settings.

1 Like

Could this be the same issue as mentioned below for the DT (When Global FX are enabled)?

I was trying to get pure white noise to filter into things. So to do this, from an initialized patch: Algorithm 8, mix all the way to Y, B1 offset to -1 so it cancels out, then introduced feedback to get a pure noise signal. And it workes, but every few presses of a key it freaks out, messing with the harmonics in conjunction with this causes more buggy behaviour. Can anyone else replicate this? Am I being stupid or is this actually a bug? I’m running 1.32a


Just checked this, and got the same result. Amazing source of glitchy noise. Maybe this is just what happens when feeding back an oscillator at 0Hz?