Digitone 1.2_ bugs discussion


#22

Hi all. Not a bug from 1.2, but a bug from earlier versions that ive noticed is still in 1.2:
I have a arturia keystep going into my digitakt, whos midi out then goes to my digitone. I then use a midi track to forward the midi output from the keystep, through the digitakt, to the digitone.
So here is the bug: sometimes when I play a note on the keystep, the adsr of the currently displayed page, for the currently selected track on the DN all go to 0.
For example: I select track one, and go to the filter page. Upon playing a note on the keystep, the filter envelope a, d, s, and r all go to 0.
Few notes:
-i have not figured out how to get this to happen reproducibly, but it happens frequently. I am ~90% sure it only happens upon switching tracks on the DN, and then it seems to happen maybe 10-20% of the time.
-ive only notice it happening to the adsr of the filter page, and the ads- of operator A on the synth2 page. I havent had it happen to the adsr on the amp page.

  • i have not tried with another midi controller, although im not sure if this would make a difference, since i am assuming only the note data is being forwarded from the DT to the DN.
    Anybody else notice this issue.?

#23

Make sure you have set ENCODER DEST to INT (and not INT+EXT) on the Digitakt.

Otherwise it will send CCs when you operate the knobs which will modify parameters on the DN).


#24

After updating the Digitone all arps are being set to off and a speed of 1/1. This may have been caused by Overbridge, it’s been acting very strange with arps in general.


#25

Yep, I noticed this the other day. I don’t know what causes it, but it was definitely something I clicked in Overbridge. I did manage to save a sound with arp settings the way I wanted them though, so it’s just a matter of being careful and/or not being too attached to the arp settings until they fix it. Not an excuse of course, but what else can we do in the meantime :smiley:


#26

Unfortunately once I removed the device from USB and restarted it, I’m still seeing this behavior. It’s now playing chords when arp mode is off and I lose all sound once I turn it back on. :fearful:

Edit: switching projects seemed to get it out of this weird state.


#27

I’m kinda nervous to update the os with all these bugs. Maybe I should wait?


#28

Give it a try then roll back if the bugs annoy you? There will probably always be bugs of some sort, the only way to go ahead is to try the new OS updates and report any issues.


#29

Yes the steps are red not yellow, this definitely doesn’t work as it’s supposed to.


#31

OK, so I spent the time to figure out how to reproduce the bug I mentioned earlier.
@tnussb thanks for the tip, checked, and the setting is on INT.

So it turns out it occurs even in the absence of a midi-controller, you just need to be playing a DN track with a midi-channel of the DT:

use an existing pattern or go to a new pattern:

  1. Set pad X on the DT to output on midi-channel Y, have the DN receive on channel Y.
  2. Load a sound onto any DN track.
  3. hit pad X, sound plays on DN as normal.
  4. hit play on the DT to start playing a sequence on both (I have the DN getting system messages from the DT), hit stop whenever after
  5. hit pad X again: now check the FLTR and SYN2 page on the DN: the a, d, s, and r on the FLTR page, and the a, d, and s on the SYN2 page have all jumped to 0.

Im using DN v1.2 and DT v1.10.

Not sure if the bug is with the DN or the DT. Also, while I can reproduce this every-time, not sure if this is the only sequence that causes it.


#32

Is there a screen saver in this version? Dont see it listed in the release notes.
Twice so far my screen went black. The first time it happened when I powered up the midi controller (that was connected to the digitone) - I freaked and cycled the power.
the second time- it happened while I was playing midi keyboard and I hit a button on the digi and the screen came back. I have it running and am watching it now, but the screen is staying strong. Bug? Feature?


#33

Feature. There is a screen saver, screen goes black after awhile. Any button press or midi input turns the screen back on.


#34

From the manual:

The Digitone features a screen saver that dims the screen after 5 minutes of inactivity and turns off the screen after 60 minutes. Press any key or move any controller to wake up the screen.


#36

After updating to 1.20 I got this issue that if I set record mode on un-quantized, my notes still gets quantized. With external midi keyboard ( keystep ) it’s always quantized, on internal keyboard, the first 8 steps are unquantized, then everything else will get quantized.


#37

After updated to 1.20 my DSP Boot Failures continue, or devices freeze upon boot up. Working with Elektron Support Staff, and will be sending the devices in for repair. One of the Digitones worked flawlessly until today. Disappointed that the OS promised to fix the issue hasn’t on my devices but I know Elektron will make it right.


#38

@captainev3 bummer, I’ve use my digitone every single day since the update came out and I have yet to get a boot failure at all. I got it every now and then before the update… But as mentioned before are you running midi into or out of the digitone when you power on?if so are you turning the machines on at the same time? Or are you usingit stand alone?


#39

That’s a shame, sorry to hear that - it seems to have fixed the issue for most units out there (certainly did for mine, actually!), but we’ll continue digging.


#40

I have tried all combinations of Midi in and out and usb in or out and stand alone. I understand sometimes having different stuff in and out sometimes helps but the product should function as a standalone as well. I’m also letting the device sit for a while between power ups which in the past has helped but it doesn’t seem to matter now.


#41

@captainev3 my point was, when I used to turn my two digitones on at the same time (while hooked thru midi) I always got a boot failure on one of the units. Never really got it when I turned them on one at a time.


#42

The only situation that caused boot failure on mine was a particular project but I was deliberately stressing the machine. If fixed it by …

I loaded a blank new project
Saved it
Turned off machine
Turned it on in test mode
Checked a few buttons.
Rebooted device.

This seems to clear the memory , refresh a few things.
Perhaps focus on a project that is only internal for a while
Add midi and see if things fall over ?


#43

I have not been able to successfully power on my DT since updating to the current firmware. Constant freezing or dsp errors.