Digitone 1.01 : bug reports


#85

Maybe it’s a different mute mode…
e.g.

  • PTN + T1 = pattern mute (jump to next pattern, T1 is not mute anymore)
  • Func+T1 = global mute (jump to next pattern, T1 stays mute).

Would you mind testing this and (dis)confirm ?


#86

From “panel layout and connectors” in manual. (Secondary function means FUNC + [TRACK] key). This behavior has been around since the Monomachine and is also present in the Analog 4: function + track = mute.

  1. [TRACK] keys. Selects which track to be active. The secondary function mutes the track.

But there’s something new. In the “Digitone Controls” section of manual - 8.5.2 “Mute Mode” (may be slightly different in updated 1.01 manual):

There are two di erent versions of MUTE mode on the Digitone:
• GLOBAL MUTE MODE In GLOBAL MUTE mode, the muted tracks are muted in all patterns, and the trig [TRACK] keys are lit red. If tracks are muted in PATTERN MUTE mode, the tracks keys are lit red when the pattern plays.
Press [FUNC] + [BANK] to enter GLOBAL MUTE mode.
Press [FUNC] + [BANK] to exit GLOBAL MUTE mode.
• PATTERN MUTE MODE In PATTERN MUTE mode, the muted tracks are muted only in the active pattern, and the trig TRACK] keys are lit magenta. If tracks are muted in PATTERN MUTE mode, the tracks keys are lit magenta when the pattern plays.
Press [FUNC] + double-tap [BANK] to enter PATTERN MUTE mode.
Press [FUNC] + [BANK] to exit PATTERN MUTE mode.
The GLOBAL MUTE mode settings are saved together with the project. The PATTERN MUTE mode settings are saved together with the pattern.

Personally, I’m still a bit confused at the muting behaviors of Digitone but I haven’t really gotten beyond single patterns yet in my early explorations.

But I think global mute mode is default.

Probably not a bug, just confusing.

You can also use QUICK MUTE to mute and unmute sequencer tracks easily. Press and hold [FUNC] and then press the [TRACK] keys to mute or unmute tracks.
Digitone remembers the last used version of MUTE mode and accesses this version first when you press [FUNC] + [BANK].

I think it’s this last bit I found confusing. I suddenly had magenta track colors and wasn’t sure how I got the magenta track colors and couldn’t seem to kill the magenta track colors as easily as I wanted to return to the slightly more understandable reds. :man_shrugging:


#87

Thanks - you’re correct. I didn’t see that because I was searching for the key combination that hasn’t yet been described in the manual (afaik) which is PTN + track button. The manual describes FUNC + BANK double-tap which takes you into the same thing on a fixed basis.

It is confusing. Still not sure how pattern mute is different to the regular quick mute (FUNC + T1 etc). And maybe there are too many colours to remember plus when you go into MIDI you see a different set up on the same four buttons. Sure we’ll get used to it.


#88

got one here.

voice allocation on track 2 is ‘1’ for a mono line.
voice allocation on track 3 is ‘dynamic’ for poly.

when playing a 16th note mono pattern on track 2 it acts like its stealing track 3:s voices. track 3 won’t play until I mute track 2.

is this a bug?


#89

Is anything playing on tracks 1 or 4?


#90

Pattern mute will work like this:
Mute T1 in pattern 1, switch to pattern 2 and T1 is no longer muted… but if you return to pattern 1, T1 will be muted again.
It saves the mute state in the pattern.

Global Mute:
Mute T1 in pattern 1, switch to pattern 2 an T1 is still muted.


#91

nope.
I have a basic 7 step pattern with only 3 trigs trigged on track 1 (track 1 is 1 voice just like track 2) . that plays fine with track 3. then I mute it.
track 2 has a complex enough 16 step acid pattern, most steps trigged with a bit of modulation. that cuts out track 3.

track 1 n 2 are on single voice mode.
track 3 is on dynamic.

it only happens with the complex enough pattern on track 2.
track 3 is just 1 note at a time, but is dynamic voiced.


#92

Does being explicit with the voice allocation fix the problem? Like just assigning two voices to it?


#93

turns out I had the patterns voice allocation set to “track”. changing tr.3 voices to a set number didn’t fix it. changing voice allocation to either “cycle”, “high” or “low” fixes it. :+1:


#94

Anyone had issues with it freezing yet? Mine was fine for the first week but it froze twice today. 1 when using midi with digitakt and 1 when using midi with ableton.


#95

I’m getting really bad loud intermittent clicks on arp tracks, at the start of trigged notes.

ive tweaked all the envelopes n parameters, turned off aenr, turned off the lfos, no p-locks, tried all voice settings. it’s proper intermittent, might not do it for the first 10 seconds but then kicks in repeatedly.

am I missing something?


#96

Yeah I can replicate that. The purple is kinda cool. But yea, not consistent with how the other submenus light up.


#97

is anyone getting bad clicks when using the arp?


#98

Yes, I thought it was about voice allocation and input, but it seems popping up sometimes anyway. This sounds like a thing elektron needs to look into. Could it be nature of FM and some sounds isnt anygood for arps?


#99

check the phase reset maybe


#100

I’ve got clicks at the beginning of notes playing two tracks with arpeggios. Each track on its own doesn’t click. Bringing down the levels doesn’t solve it.


#101

It’s freezing with midi loopback, sometimes doesn’t freeze but stop responding to midi messages.


#102

I’ve submitted a ticket.


#103

phase reset doesn’t fix it unfortunately.


#104

…another fresh baked digitone user…

right out of the box today…setting up…all conections with digitakt are fine…and work as expected…
out for a coffee…
back in the studio…starting to work on it…first ten minutes…two full on crashes already…hmmmmm…
both in arp situations…so that construction side is defenitly also overhere confirmed, for example…and also that popping/clicking at the beginning of some sounds…

obviously lots of homework left to finish, up there in sweden…
and no, i don’t need overbridge at this point…priority here is clearly, make your machines rock solid stable for stages…and only THEN you can make them ready via OB for further deep dive studio missions…

i’m used to swedish bugs by now, since digitakt is still driving me nuts every now and then, since end of summer LAST year…
and also as a first adopter of the octatrack few years back…
so i completely see the point in giving birth to „dtakts best friend" 'til namm18…
and hell yeah, i don’t learn from my first adopter mistakes…because you swedish guys are the last ones in this business that can trigger my gear junkie instincts…and hell yeah and hell yesh, your machines all sound amazing…so here we go…again…not loosing my faith, whether my hopes…
you gonna fix this, no doubt…but when?

so…YOU guys got no excuses left anymore…better don’t dare to bring out another new machine before some things in your mk2 and digi product families are finally settled and FIXED…

so NOW, my swedish friends, u finally got to deliver…really wanna see an os 1.02 for dtone and an os 1.05 for dtakt pretty soonish…
new updates that really bring this two machines together…working as one…rocksolid…your half way there, yet…
i don’t mind if there are still some bugs left somewhere deep in the machines…
specially when it comes to OB versatility…
i’m sure all those huge OB promises will bring along quite a few more troubleshooting…
…that said, i really digg your tendency to think big and fast forward…anyways…

but no more too obvious bugs left anymore 'til THIS SPRING, please…
hear me…?
thanx…