Digitakt send CC to Roland TR8-S?

I’ve got control over the drums in the TR8-S from my DT, but I can seem to get the CC’s to work. I cant tell wether its a DT issue or TR8-S issue. I’ve mapped CC 20 (BD Tune on TR8S) on the DT and yet nothing happens when turning the knob. I cant find in the TR8S manual where to allow incoming CC messages, but I know i’ve seen YT vids of people controlling its CC’s thru Ableton and also and IOS sequencing app. Anyone have any suggestions?

anyone? I’m sure someone here has done this already.

I used mine to drive tr8
I just suggest you check obvious things ,
Using midi out A , not midi b
Track isn’t muted
Midi cc send us turn on
Midi channel set properly
Midi receive turned on tr8s
Try another midi lead

Try another box to send cc ? Just to check it’s working.

Can I ask about externally sequencing the tr8s - is each sound on its own midi channel? When I had tr8 I didn’t like the sounds were all in one channel. Cheers

There’s probably a manual online .

I have a Digitone and a TR8S. I can check quickly after breakfast and reply with some instructions. I assume the Digitakt will have the same or similar setup for the MIDI tracks.

2 Likes

Lots of people post useful things that are in manuals.

I’ve read the TR8-s manual and there’s nothing about setting incoming or allowing incoming CC control. It seems like they neutered the midi in to only allow playing the drum sounds, but the USB does allow drum sound and CC control. If that’s the case, that’s pretty lame of them and also a super easy firmware update. I’ve tried with the OT, DT, and DN and no success other than being able to set to channel 10 and play the drum sounds on the TR8-S, but no cc control using the CC chart provided by Roland.

1 Like

and also I wish people would stop just saying things like “i adjusted the settings so I could use the CC’s and …” but never saying what settings they adjusted. Why make a tutorial and skip over crucial steps? Just a rant, but geez its frustrating.

Maybe you forgot to enable the MIDI channel on DT’s side? It won’t send anything out if you don’t.

Edit : nvm I see you tried channel 10

kinda weird omission but oh well there’s always one

1 Like

Roland are experts at leaving out simple functions that would make a good piece of gear great

That’s why…

Elektron

2 Likes

I was just in the same position about this with my digitone and tr-09

I meant to look into this for you after my breakfast on the weekend but the day got ahead of me. As luck would have it (or not), my main outs died on the TR8S while at a jam session that evening. It’s off for repairs for the next little bit. I will not be able to investigate for you.

I’m wondering though if maybe changing the MIDI channel of the TR8S to something other than 10 might help. The Digitone uses 10 as the auto channel and I wonder if trying to send MIDI using that channel causes problems? Set the TR8S to another channel using the Utility menu. On the Digitakt, make sure that the MIDI channel is enabled on the track you are using. On the Digitone, you can set the track MIDI channel in the MIDI setup page. You also need to enable the MIDI channel in the channel itself. That took me a few minutes to figure out when I wanted to setup MIDI on the DN.

Hope you get things sorted out! I seriously doubt that there are two different MIDI implementations on the TR8S (one for USB and a limited one for DIN).

Thanks for the suggestion. I’ll try that today. I hope Roland gets you back the TR8S quickly!

Might be a step back to go forwards but I installed midi ox to check the Digi was sending cc changes.

I just assumed you were having a 2 day breakfast.

1 Like

That’s how we roll in these parts :wink:

1 Like

coming back to this… someone has figured this out. I’ve tried everything and its pretty dissapointing that its not just simple. If they give you the CC chart, one should be able to use the correct midi channel and send that cc# and expect the control. Is anyone using an OT or DT or any Elektron box to send CC messages to a TR8-S?? it can just be me.

WAIT! i think I just figured it out by freakin adjusting everything in the midi page of the tr8-s I could and found that if you turn MIDI: RX EditData from OFF to ON (default is off) it works! Now i can finally make the tr8-s sing by freaking it out with CC parameter locks and trig conditions.

4 Likes