Digitakt OS 1.05

Yay! Updated flawlessly. Manual was also updated btw

I work with special needs individuals. My main day client has autism and perfect pitch. And Can basically play any piece of music on piano just by hearing it. Super rad. But totally off topic.

That’s why I didn’t mind waiting to get home from work today, but now all I can think about is this digitakt update.


Introduce him to the Digitakt, problem solved!



Loopback works if you disable all MIDI sends from the internal controls and avoid pressing stop twice. Pressing stop twice will result in feedback due to all notes off being sent as per standard.

(However, I think having an option for the all notes off send would be nice.)


A post was merged into an existing topic: The Digitakt Feature Request Thread

Thanks @Ess

Damn. I was really hoping that they’d add MIDI Retrig with this update. Alas. . . .


Can anyone confirm that the clicks and pops have been fixed? (I am still stuck at work)

Could you or someone else explain midi loopback? Sounds interesting :slight_smile:

So are there actual “Sounds” now. Or just still samples?

My Digitakt stalls when I go to the OS Upgrade page. The no button doesn’t work. I can’t send the SYX file at all. Any ideas? Elektron Transfer shows 0% sent.

Midi loop back is when you plug the dt’s midi out into the midi in of the dt.
This allows you to use the midi tracks to affect parameters on the dt
More lfo’s! Parameter locks for fx’s!


This explains it!


There have always been sounds. Sounds are a sample + the parameter settings saved in a nice package


anyone having issues updating? I had no issues on the first update. Transfer wont connect and C6 wont see the DT.
Trying Elektron USB thru Overhub and using direct and other USB cables. Same results. Also I’m trying using the power-on/Func combo and Os Update in the settings. Both wont work.

Excited to try this out, hoping the late pattern change bug has been fixed and just didn’t make the release notes…:crossed_fingers:

1 Like

That’s a shame. @Ess, would you be able to confirm this please? :slight_smile:

1 Like

I still cant audition my sounds in the sound browser…

Problem solved. O.k just in case other people have the similar problem- I had a midi cable and usb midi connected. Unplugged the midi cable and everything went smoothly.