Digitakt + o-coast | sending cc via midi-lfo

hello there,

anyone here who experienced problems when using dt miditrack-lfo´s to send cc to the o-coast. i try to address o-coast internal clockdivider to randomize it (via cc#116) but it doesnt seem to work properly- changing lfo-speed, lfo-wave etc. has no effect and when lfo-depth is set to zero the modulation is at maximum. really strange.
using the midi lfo´s to modulate one of digitakt standard track params works great. also p-lock cc#116 values works but sometimes o-coast seems to miss single notes. hmm… maybe its a o-coast midi issue?

btw. i am running the latest digitakt os 1.11.
any help is appreciated. thanks, j

i don’t have my 0-coast here now, but i remember that you have to access the MIDI-CC functions by setting it to the specific mode before they have an effect…

/edit: you could also try accessing it with the MIDI-learn functions:


thanks, what kind of mode you mean?
of course i have to enter the programm page to receive cc by pressing and hold “PGM A “. but i guess thats not what you mentioned?

oh, that is exactly what i mentioned :joy:
sorry i could not help…

no problem, thanks anyway.
i will contact make noise for that and report back here …


It works for me.

I set the 0-coast to it’s default settings. Set CC1 to 5 and the LFO depth to 1. Used a random LFO in HLD mode.

1 Like

thanks for chiming in.
guess what. now that i follow your settings it works for me as well.
also for clockdivider.
hmm but didnt change anything but the cc1# and depth… not sure if my
o-coast midi interface works 100% stable. have to reset my unit to default settings over and over again…

btw. set lfo depth to 1 doesnt make an audible difference to 0 for me. did you meant 64?

1 Like

No, I did use an LFO depth of 1. I get wild swings if I set it to 64.

Maybe you were swinging the clock divider too wide and went super/sub sonic?

I do get weird behavior when I turn the midi clock on the 0-coast.


ok after some more tests i assume that the digitakt outputs cc when changing the lfo-parameter on the midichannels. (guess that goes for all parameter on the dt) . since i have no audiointerface i cant prove it. anyone here who can confirm that behaviour?

if iam right the outputed cc messages overlaps with oc internal cc and causes the errors that i experienced.

EDIT: in the midi config menue/port config/param output.
it must be set to nrpn NOT cc.
that solved the problem for me.


1 Like