Digitakt MIDI settings - with virtual instruments

First, of apologies for the newbie questions, I’m not only new to the Digitakt but also to MIDI.

From what I 'v gathered thus far the Digitakt has 8 midi tracks available.
How much control you get can over each channel depends on the hardware you wish to control.

So with 8 midi tracks that can each be assigned to a midi channel, I assume could have a different instrument assigned to each midi track/channel ?

What I want to achieve is to set up so that Digitakt uses virtual instruments in my DAW, Studio one 4.5 is preferred but I do have Ableton Live lite as well as FL studio 20.

I have the Digitakt connected to my iMac via the Elektron Overhub and have the USB setting to midi (instead of overdrive) which I assume is correct?

The thing that puzzles me is how to set up the Digitakt as a midi device in the DAW. In Studio one I have it set up as an instrument like this.

I do get a connection and can trigger some instruments, but they aren’t isolated to the channels i set, for instance in studio one it plays whatever instrument i have selected in the DAW on all channels.

Im sure there are things i need to set up correctly to get this to work. :slight_smile:

Any help/advice or pointing to a guide would be most appreciated. Thank you!

dont know studio one, but according to your pictures you are halfway there.

on digitakt you should set a different midi channel for every midi track. eg. 1 to 8

in you daw you have to route each specific channel to the instrument you wanna play… so tell the channel with the vst to only listen to midi channel 3 for exmple (midi track 3 on dt)

also in your picture you route digitakt in channels to digitakt out again, that seems unlogical / unnessecary. you should route it to daw or a specific channel, like i wrote above…

oh, and welcome to the forum :slightly_smiling_face:

Thank you for the response and the welcome, appreciate it!

My reasoning for not activating all the channels but only 9-16 was simply because I had assigned channel 9-16 to midi track 9-16 on the DT. I assumed the channels 1-8 should not be used as they are assigned to track 1-8 on the DT?

On that note am I correct in assuming that the channels for track 1-8 should be turned OFF on the DT ? (unless I want to control them over midi ?)

The send out should be set to none instead of going back to the DT ?

Finally just to try to determine if I 'v setup up my DT correctly I 'v provided a few poor cellphone snaps of the midi settings.

Thank you!

So i finally found out the issues in Studio One 4.5

I had to split the channels in the MIDI settings to get it to work!

I got it to work in Ableton Live 10 quite easily, easier to assign a midi channel to an instrument.

Either way happy i got it to work, but i realise i really need to read up on MIDI :slight_smile:


Hey I’m trying to setup my Digitakt in Studio One 5 that just released, which isnt too different so far. Can you explain what you did to split the channels and get it working? I’m trying to assign a VST to each midi track more or less and it’s proving more stupid than I anticipated. :frowning:

If you look at the first screenshot i check “split channels” and that worked. I do not have the Digitakt or Digitone anymore so i can’t really test it.

But i do find setting up MIDI in studio one a lot more work than say Live 10.