Digitakt controlling OTO Bam via MIDI

hey all. was wondering if anyone has had any luck controlling the oto machines bam with midi from the digitakt? i’ve got the digitakt sending program changes to the bam to change presets, but nothing appears to be working. is there something i’m missing?

troubleshooting i’ve done so far:

  • made sure digitakt and bam are on same midi channel
  • made sure both midi filters are turned off on bam
  • tried using trigless trigs AND note trigs to send the program change from digitakt
  • reset bam to factory settings
  • tried connecting machines via midi cable in a variety of orders (having one machine on then turning the other on, turning both on at the same time, unplugging midi cable and plugging it back in, etc)

i’ve scoured this forum, the oto machines forum and the digitakt facebook groups without acquiring any helpful info. i e-mailed oto machines support but haven’t received a response yet. the bam sounds SO good but this hurdle has been frustrating to say the least. how nice it would be to send program changes so that the preset will switch itself as patterns change on the digitakt.

thanks for your help and my apologies if i’ve missed a thread where this question has already been answered.

Hi, it might sound obvious but did you enable Program Change Send on the Digitakt? It’s in Setting > MIDI Config > Sync, and it’s disabled by default when you create a new project.

You can also tweak the Program Change Out Channel in MIDI Config > Channels to see if it helps!

i did! i forgot to mention that in my first post. thanks though! that would be a very easy thing to over look.

Hi - did you ever get this to work… ?
Curious if these two work well together.
Thanks.

Hi,

here is a firmware update for the program change issue BAM_rev_1.4b.syx (105.0 KB)

Denis from Oto Machines made it for this purpose.

2 Likes

Anybody tried this new firmware out?

How are folk getting on with midi+OTO?

i actually got this to work without updating the firmware. i legitimately do not know exactly what settings i landed on to make it work, but it’s working consistently now. i can check later today when i get home from work what settings i have on the digitakt and bam. i can tell you that i consistently hook up the midi cable to both units while they’re powered off. then power on the bam, wait just a sec and then power up the digitakt. i’m not sure if that sequence makes a difference, but i’ve heard that it can, so that’s how i’ve gotten it to work. will post midi settings later.

i’ve just been using it to send program change messages to change saved presets on the bam, but for that purpose it works great. i haven’t attempted to try to control the reverb parameters with midi sent from the digitakt.

2 Likes

Thanks, considering a Bam and want to control it from the DT so very helpful