Digitakt 1.11 : Bug reports

Roland’s documentation is not good but it is likely that the BANK and SBNK settings are not necessary. Because the System-1 only has 64 program memories, you can probably set those using only values of PROG from 1 to 64. Edit to correct: it seems my guess is wrong; I read on the web that you need to use SBNK in the range from 1 to 8 and then PROG in the range 1 to 8 to access the 64 locations. BANK should have no effect.

The P12 should not respond to BANK, only to SBNK and only in the range from 1 to 4.

Try these values in case they work. If not, we can investigate further.

1 Like

Thanks for getting back. What a late night. At the end of the night around 3am I open a new project and it worked. I then tried opening some old projects and it worked most of the time with a few glitches depending on what patterns I chained. Weird. But basically works. Yep Roland doc’s are a bit thin. Last night I got the SBNK to work which is cool because before it would only select 1-8 patches but now I can select all of them! sweet. I still think there is a bug in there especially in older projects but hopefully this will get sorted as I couldn’t get it to respond perfectly with all projects. Thanks again.

1 Like

Yes, sadly mee too. Just updated my DT to 1.21

I am encountering the same problem. I popped on the forum to see whether I was alone in that. Guess not!

We encountered ^this issue upon updating a week ago and created a support ticket, but there’s still been no answer and we only have 3 more days before Elektron goes on holiday for the better part of a month. :cold_sweat:

Bug or interview foreshadowing? Hmmm.

That’s weird.

I’m on 1.11 and unable to reproduce that with the same settings.
Mine loops at 4.

I even put on some Radiohead, but no change :thinking:

1 Like

yes same problem here

1 Like

So I admittedly didn’t go through the settings of each track: (This is also just one of several effected patterns)

1 — 46 steps; 1x
2 — 38 steps; 1/2x
3 — 46 steps; 1/2x
4 — 23 steps; 1/2x
5 — 50 steps; 1/2x
6 — 19 steps; 1/2x
7 — 63 steps; 1/2x
8 — 21 steps; 1/2x

Obviously, the first thing I tried was to set the scale of the first track to 1/2x, and use microtiming and retrigs to retain the same pattern, but the issue persisted.

The issue being that upon the first iteration (play through), it counts a step longer than the Master Length.

I’ve seen several suggesting to set the Master Length to INF, but we intended to go with a Master Length of 184 to allow things to phase and displace a little bit without getting too out of hand. (The track’s in 23/4.)

Right now, the only workaround (aside from
reverting the OS) I can think of is to duplicate the project and pattern push the trigs of each effected pattern once to the right, so that they snap into place upon the second iteration.

:laughing:

I’m trying to change a sample on a particular step via parameter lock, but the lock won’t happen unless I press “yes” after selecting a new sample. In previous updates, I was able to change the sample lock by pressing down on the D encoder. Is this new with the update, or am I just going crazy?

The TEMPO button is now always lit white and flashes red on the beat.
Is there a ‘function’ enabled when it’s lit white? The red flashing is barely visible when you want to follow the beat.

You sample lock by holding a step and turning the level encoder. :tongue:

Note that you have to populate the “Pool” first (which is different than your sample list).

Had the same problem. ended up being in digitakt mode instead of midi/usb.

I don’t really understand the response here. I just updated to 1.11 and sending program changes over MIDI seems broken. The Digitakt used to send program changes over each MIDI channel where a patch and channel were set each time the sequencer was started. Now it only sends program changes when some parameter on the MIDI SRC page has been changed. I confirmed this with MIDI monitor. @Elektron any clarity on this?

Oh and also double-pressing the stop button sends the pattern number as a program change message over the Program Change channel, which seems like it didn’t used to happen because that’s changing the patch on one of my synths.

RENAMING BUG

Hello, sorry to mess up your day with some more bugs to squash.

I 've been happy fiddling about with the DT and almost immediately soon after, those bits and bobs were all over the place multiplying like wildfire. So i thought by actually naming/renaming patterns/projects in a logical order i’d somehow keep track? (which parts to keep/what to flush, build upon etc…with the intention of actually finishing up some stuff)

The Bug-part:

When i rename a part (PTN within a PROJECT) and use the ampersand ‘&’ it shows up as a ‘%’-sign ? (in active overview window: )

When i use a ‘%’ it doesn’t show up at all while nibbling away some other characters as well?

Haven’t checked/used all the additional charactters yet, so can’t tell if it’s just these two, messin’ about?

Okay, thanks
Cheers!

After installation of 1.11 it seem like Overbridge and Digitakt are a bit unstable in Studio one (4.5.2). Sometimes it work, but sometimes it just don’t sync with my DT in Studio One.

I can’t really see what cause this problem. Anyone else have similar problems? Running Windows 10 64 bit. Run latest Overbridge 1.36 Beta2.

My Analog Four MK2 work great.

Not sure if it’s the same thing, but on Win10 with FL Studio I see 30 second delays when initializing the DT VST plug-in.

When I switch files, I noticed that in the lower left of the DT VST it says “initializing please wait” (or something like that). Are you seeing that? It took me a while to realize this was why I wasn’t getting audio from midi from the DAW to the DT.

The good news is that after it initializes it works fine. As a work-around, I restart FL Studio because it’s faster than waiting 30 seconds for the DT VST to initialize.

I filed a support ticket about this a few weeks ago, and sent debug logs, but have not heard back yet.
I’m assuming their support gets pretty slammed when a new OS goes out.

Best regards,

Gino

Hi Gino.

Yes it states something like "Initializing please wait. It freeze there. No problem with A4MKII. Had no issues before, worke perfectly. Triede to turn on before Studio one. after the program runs. What also happens is that the Elektron Engine for DT stops. Not for the A4MKII…

Don’t know where to go from here. Might need to go back to previous version.

1 Like

I have the same problem, as Garf, bug that will cause a trig with a ‘1st’ condition to retrigger at the loop point of each M.LEN when certain track scale settings are used, but not on all the paterns, it disappears by positioning M.LEN on inf and positioning the value on CH.LEN but it reappears when I change patern.
Same problem as vvilms, the same buging patern by setting the M.len value to 4, the first measure is 5 steps!
have these bugs been reported to the Elektron team?

1 Like