Digitakt 1.07 : Bug reports


#1

Firmware 1.07 is now released.
Discuss here

Remember to back up before upgrading and even load a new empty project to avoid any damage to your current project.
And avoid upgrading before a gig. :tongue:


You encountered something wrong in OS 1.07 and want to check if others can replicate it ?
Here is the place.

Doesn’t replace a support ticket, of course, but you might want to check if it’s not a feature before declaring a bug :wink:

Please report all bugs via the Support Tickets section on elektron.se if they have not already been confirmed below.



#2

Beware, a bug was reported on a FB group…

https://www.facebook.com/groups/1014802845333089/permalink/1303120606501310/


#3

Don’t have Facebook, what is the bug?


#4

Haven’t tested yet myself, but from what I understood when you use a sound lock, standard steps would sound like the sound lock.
To be confirmed.


#5

Loading sounds to pool still doesn’t load its proper sample to sample slots if a certain amount of samples is already loaded in ( up to 60 or 80 after multiple tests since OS 1.06 ) and sound locks so use other samples already there randomly


#6

Previewing highlighted sound by pressing trig key 1 to 8 works only for the first sound you browse. It seems to continue to preview this first one altought scrolling them.
When you start to preview them by standard func+yes, trig keys (other than the one you start searching sound) just play their own sounds, no preview

Access imp/exp via func+pattern menu also still not accurate and often drive you to simple pattern menu apparently depending where you were last time.

8th row has gone in ram view list


#7

Not sure how to replicate this but one of my tracks had its mute lights “delayed” for both global and pattern mutes, like it would show only its previous setting while the rest were working normally. Having all tracks activated for example meant only track 4 would be unlit for both global and pattern. Has anyone else encountered this strange behavior? :man_shrugging:


#8

I reported this one for 1.0.5. Sounds like could be the same issue as the fb post (can’t view the post as it’s a closed group)?


#9

Yes, seems pretty much what was on the video. I looked at it again in the morning and it’s exactly this. Isn’t even related to sound locks.

Please submit a ticket to :3lektron: support if you haven’t done so already.
Thank you @garf.


#10

All good, bug was submitted last week. Hopefully won’t be long til fixed.


#11

:pray:t3:


#12

Yup no such problem with sound locks, just the weird behavior garf reported before.

In an other side could you confirm the « load into Sound pool issue with sample » i mentionned up please.
I ve send already ticket when 1.05_06 with no response, and sent again yesterday for 1.07.

When i asked in the last bug report topic nobody noticed it apparently, so i feel quite alone with this bug.
Much thanks


#13

Previewing user sounds still doesnt work.

mute mode is not remembered after turning off the DT


#14

How do you try to preview user sounds?


#15

:scream: all is empty after upgrade to 1.07. Drive + soundpool empty, me patterns gone. In the upgrade notes (from Elektron) it wasnt stated (besides can u backup the Digitakt?).

Maybe the samples are 2 be found somewhere so I can reload them.

Not sure if this a bug, feature or me being to lazy reading manual/warnings …


#17

Sysex back up for everything but samples was added in 1.05. It should also be noted that the dt hastags samples with an identifying number so if you still have the samples you can reload them to the digitakt and it should be like you never took them off.


#18

The samples (factory content) are there … via the sample menu. But I propably have 2 read the manual more carefully, so I can load them back to Drive + soundpool. Patterns gone forever methink …


#19

in the sound browser - func and yes. works with factory sounds nicely


#20

Shit man sorry to hear this :pensive:

I am worried now, I updated tonight and made a track in a new project, haven’t tried loading any of my previous project yet :cold_sweat:


#21

I sent a support ticket, but since upgrading I’ve had an issue. After turning the machine off for like a half hour or more, when I turn it back on my sample assignments and track parameters are reset but only on track 1, and it’s only on new patterns I’ve saved since being on 1.07. It’s not just happening on my current project but my other one as well, again only on new patterns. I haven’t touched old ones so I don’t lose anything.

EDIT: My last OS was 1.04 and I didn’t notice all of the added midi settings in 1.07. After setting all the Midi Tracks to “Off” I haven’t been able to replicate the issue.