Digitakt 1.03 : Bug reports

The current workaround would be repeat the 1st pattern in the end of chain (A01-AXX-A01).

I think would make much more sense to select pattern/banks by holding PTN/BANK button and pressing the desired number. Would be more intuitive and consistent as Func and TRK buttons also need to be held. And this way chaining patterns would be like holding PTN then selecting pattern numbers in any order (until you release PTN).

1 Like

You can change how many times a pattern plays before moving on to the next in the chain on the scale page (per pattern) but this is fixed for every time that pattern is played. You could copy the pattern and set one as a single loop and the other as a double loop. But yes, ideally, would be good to select multiples in the chain like you describe.


good tip,thanks

Some unreported 1.03 bugs AFAIK:

  • Sometimes (Func+Yes) preview function doesn’t work on sampling screen

  • If you p-lock a note length to “Inf” on midi tracks, it prevents next notes to be triggered.

  • When using a external midi keyboard in grid recording, you can p-lock notes only if using auto channel (not a big problem but worth the mention)


I would have thought this is intentional otherwise it wouldn’t be infinite and would be cut off by the next note.

2 posts were merged into an existing topic: The Digitakt Feature Request Thread

I hope to see 1.04 soon with all midi issues solved. It can’t be that something as basic as midi doesn’t work properly and crashes this much.

To sweeten the pot Elektron could make me happy by adding sample slice/chain support and scale per track like on the other sampler (OT).

1 Like

Did a little track on Sunday with Digi, Eurorack, and a Sub Phatty. Pretty stable (although I only used factory samples and didn’t sample or import anything).

I did come across a situation where Midi A wouldn’t play anything in a newly created project, it didn’t matter which channel I chose, no MIDI notes on DIN or USB. But I could not find anything wrong. Fixed it by copying the (working) Midi B channel TRK onto Midi A in the same pattern.

Also the FUNC+COG save project crashed once. Menu saving has been ok.

Is the Digitakt supposed to be able to P-lock “function + all” changes in the realtime record mode? I could have sworn I did this before the last update but may be doing something stupid…

(post withdrawn by author, will be automatically deleted in 24 hours unless flagged)

1 Like

At some point my MIDI control of synths stopped working and I have yet to figure out whether it is my fault. I don’t think I changed anything and it worked fine. The report of BlackDoors might suggest that it is a DT problem? With so many basic problems (eg freezes pressing a normal button combi) the trust in the machine suffers. With no option to backup things, one is also hesitant to invest too much time (unless one is just interested in doodling). This is quite different to the other machines where I could be pretty sure that it is almost always my fault when a problem occurred. I therefore also hope for the next update to raise the spirit again :slight_smile:


oy - just ran into this, too! Did you file it, or should I file it, too?

1 Like

I filed it, but dont hesitate to re-file :slight_smile:


I’m getting pops and clicks from time to time. This is without anything being connected to the DT apart from headphones and power. Anyone else experience these? It is pretty much impossible for me to reproduce this so I’m not filing any tickets yet.


yes… I’m getting these too from time to time. Eliminated other possible sources, these pops are definitely coming from DT. Also not sure what’s the cause, haven’t methodically hunted for this as it’s usually happening while being in the middle of something… people have said that it happens when DT is clock-slaved, which is a thing I’ve never tried. Definitely happens when it’s not slaved.


Yeah I’m getting them with nothing connected at all. It’s also not in the samples, it happens sporadically seems. Which is bad news for us bug hunters. Could be bad news in general…

IIRC I think either @Ess or @Olle replied somewhere that it may be related to grounding/electrical problems in a setup? Not sure tbh…

fingers crossed that it’s a bug in the audio engine and not hardware related.

I’ve noticed some other slowdowns with the unit as well, sometimes the UI would become a bit laggy, and at least once the MIDI clock output to Rytm seemed lagging behind - not drifting apart, more like lagging and then catching up again. So I think there might be some code which needs optimization, possibly CPU gets maxed out at times…


Hmm… I’m quite sure that isn’t the issue here. I’m using grounded outlets that have their own group in my music/hobby room. It also happens in other spots in the house where I plug it in. Doesn’t happen to any other gear.

I’ve also noticed the sluggishness in some areas. Like browsing the sounds (func+level) it feels rather lagged scrolling there. It also happens right after starting up so I think there’s no memory leak there.

1 Like

hm. interesting. Last week I could swear that it was due to incoming clock on USB. The week before I tought it was the MIDI-clock-IN.

If it was a hardware related bug it would appear in every situation. I watched this only on external sync mode…

Today I had a very strange experience with my DT:

Despite normal (sequencer-)function suddenly all midi-out signals on every channel and on every midi track were gone. Chromatic mode did not send any note out. I tried reboot and all possible midi-routing but nothing worked.

Then I connected my easiest midi-gear 1:1 to DT. It triggered a note (on Streichfett) but it sounds like audio out was modulated (resp. overlayed) by an LFO affecting a sub oszillator. Quite possible that is was at 50Hz. The same Issue appeared on Bass Station - no DAW connectet, no other synth online.

After factory reset the problem had gone.

1 Like