Confirmed: Machinedrum MIDI in phase problem

Track 1 is routed to C (3 in my interface input), all other tracks go to main (1/2 in my interface).
From Live I simply route MIDI notes to the track channels (10-11-12-13) through an External Instrument and record the output. The inversion problem occurs on every track - i.e. both if I use the C output or the main output (I tried to repeat the test on track 1 and track 2 and the result was the same ). It should not be an issue with the outputs - as both sequencer trigs and incoming MIDI notes output on the same audio out(s). And still, the output signal is inverted if generated by incoming MIDI data :frowning:

Seems very, very unlikely to me that sounds triggered via midi would be inverted.

I definitely see the inversion between master and the external outputs.

I can check for you later tonight when I’m in front of my MD.

1 Like

Much appreciated. Yeh I know it sounds very weird… thx

Is this happening for other machines as well, or only for the BD?

Any machine (tried TRX-BD, TRX-SD, GND-SN, GND-IM), any track, any audio output

BTW, if I live-record the MIDI input and then play the pattern back and record the audio from Live, each note produces the same audio wave - i.e. the audio is not inverted. Only if MIDI notes are received from MIDI in - and only for those notes (sounds produced by internal trigs are not inverted)

2 Likes

Confirmed. Midi triggered sounds are reverse polarity.

What a strange, strange feature.

I’m guessing it has something to do with the velocity -> volume code that they implemented. somewhere along the way the signal got switched.

2 Likes

Thanks for checking this out. Now I know it’s not just me or my setup …

I also think it has something to do with velocity processing. Sequencer trigs have a velocity fixed to 95, but it seems to me that MIDI-triggered sounds with the same velocity (95) generate less loud sounds - which could be a related issue.

Guess there’s not much to do to fix this - was preparing a live set with a mash-up of sequencer patterns and clips, but at this point I have to drop the idea as this is causing a lot of audio issues

Elektron Support was very helpful and had a look at the issue. It has been confirmed as a bug.

Just reporting it here for posterity in case someone else hits the same problem.

Solutions:

  1. Do everything in the sequencer and don’t send notes via MIDI :slight_smile:
  2. Do everything via ext MIDI and place a Utility with phase reversal on the DAW channel that receives audio from the MD
  3. Mix and match sequencer-triggered and ext MIDI notes in separate tracks. Use the individual outs for those tracks that get MIDI from the DAW and use place a Utility with phase reversal on the DAW channels that get audio from them. You loose the ability to use the MD master effects on those tracks of course - but at the end of the day you can do the same in the DAW that sent the MIDI notes to the MD in the first place. Getting ext MIDI to sync nicely with sequencer-trigs on the same track is a bit troublesome anyways - so you’d probably want to segregate the track outputs based on their inputs even if this problem weren’t there.

So, if you need to finger-drum e.g. from a MIDI controller / drum rack, you probably want 2.
The most generic albeit somewhat limiting and configuration-heavy option is definitely 3. (if you have audio ins to spare in your audio interface). Of course 1. is the ticket for all cases where you don’t need/want ext MIDI to trigger tracks (of course sending CC works just fine with no issues).

4 Likes

Damn, thank you for this clarification. I was really upset one time when I made a small sample library with my Machinedrum and Monomachine. I was triggering the hits from Ableton via USB MIDI interface, and all my recordings had the phase messed up. I was using these samples and when I pressed “MONO” on my interface, the drums disappeared… LOL.

I finally realized that everything I recorded from the silver machines were perfectly out of phase.
I scrapped the project with a note on those folders that said “phase issues!” and will have to go back and run Utility on all those samples (or will have to find some way in python to process all those samples to make them use Left only or whatever)

This post at least confirmed what I thought. And from here on I guess I’ll just use the internal sequencer which is great anyway.

Just figured I’d respond to also add that the Monomachine has the exact same bug.

1 Like

This explains a lot. I´ve noticed that sometimes sounds are not as loud when i shift play modes (send notes or use the sequencer).
Besides this issue, sending notes via midi to the MD is notoriously bad synced. The only solution is just sending clock and running the internal sequencer.
Also, sending midi cc´s when using the internal sequencer is troublesome since they are out of sync i have to send f.ex. a mute one step earlier than the note it should affect.
MD as master clock and / or only internal sequencer + song mode seems to be the best solution for everything.

I am considering getting a MD.

Has this phase inverse issue been fixed yet?

I don’t see anything in the release notes for the OS, but that doesn’t mean it wasn’t fixed at some point. It’s a pretty simple workaround though and only affects you if you sequence the MD over midi (as opposed to the internal sequencer.) I can’t say I’ve ever encountered it.

Thanks.

I would be triggering the drums form an external source and into an analog mixer, where I dont have the option to phase reverse.

It will be recorded as a whole mix, so there is no option for post processing only the MD.

I just think it should be fixed, its a small issue and should not take that much of an effort to do so.

Frustrating. Btw I suppose you don’t sequence and midi play the same sounds at the same time…

why would the reversed phase be a problem for you in this scenario in the first place?

it is surely an annoying bug, I agree - but I´ll doubt that it´ll get fixed, the MD is 15+ years old now and hasn´t seen any updates in a while.

but in a normal setting where you´re not trying to double up on sounds, phase usually is not an issue at all, I feel like people are getting spooked by the word alone…

so let me put your minds at ease:
unless you also plan to record a “room mic” of your MD playing through speakers and mix that back in with the rest of your “drum set”, you probably won´t have any problems because of the shifted phase.

that is only ever really a problem when recording live drums/instruments with multiple mics, to my experience.

if you plan on layering samples and something phases/cancels out - flip-phase one of them, most of the times that´s all you need to do really.

2 Likes

MD is legacy, no longer produced, no more updates.

The phase shift is an issue, yes. Cause most other devices has correct phase.

Phase can be a problem in many cases. For example if you are making kick and bass for trance style music, the phase of each of them are essential to make the kick and bass flow correctly.

But yeah since its legacy I guess I should not get my hopes up. Atm they seem to be focused on these lower budget machines. Maybe a new version will arrive in same format as Models:sample or the Digitakt/Digitone.

But I guess only time will tell.

either way, if it really really bugs you, you could do this - provided you are running balanced signals:
-> on an XLR cable, open up one end and switch the wires from Pin 2 and Pin 3. (similar for TRS).
now your cable will reverse your phase.

5 Likes

Or just hit the Reverse Phase button on the relevant channels pf your Mixer, Interface or A/D converters.