Can a Slave MachineDrum trigger some external synths and modules via MIDI?

Hey all,
I use a MachineDrum SPS-1 MKI as a sequencer/Drumsynth and i recently bought an analog rytm MKI, I found it best for my setup to slave the MD to the Rytm, everything was fine, clock, P changes etc, but since the MD is Slaved by the Rytm it no longers transmit any notes to my synths via Midi Machines, is that a normal thing or am i missing something ?
I already fiddled with the global midi and sync parameters but it won’t cut it :confused:
here is how everything is laid out :
Rytm midi out to MD midi in MD midi out to Quadrathru and quadrathru out to various synths ins
If anyone encountered this problem and solved it i’d be more than happy to hear how!

This usually should work. Having the MD receive a clock does not mean that it cannot send any note and/or CC values.
Does the quadrathru has Dip-switches on the back? Some midi-thru’s offer Midi filtering, that way I once took quite a while to figure out a mistake myself as a switch was misplaced by mistake.
Other than that you can try and error. Un-plug the rytm->MD connection and see if the problem persists. Furthermore on what OS version is your MD?

Thanks for answering!!
I’ve tried sending notes with a midi keyboard to the quadrathru and the notes were sent to the right midi channel so the problem comes from the MD. I also unplugged the midi chord and it still didnt work. I’m on the unnoficial x0.4 OS.
thanks for helping me :slight_smile:

I just tried to recreate this. For me sending midi notes to ext. synths works as intented no matter if MD is slaved or used as a master.
Or are you trying to send notes from the AR to trigger MD’s Midi Tracks to trigger the ext. synths?
Anyway, try to update your MD to X.05b hopefully this helps!

Btw, welcome to the forum :slight_smile:

Oooh thank you i wasn’t aware that the unnoficial OS got updated! I’m only trying to send notes from the MD to external gear nothing more. I will try to update tonite.
What is MCL btw?
Thanks a bunch

1 Like

MCL is the software running on the Megacommand which is an open source Midi-controller specialised for the Machinedrum. It is quite a nifty tool, allowing to use features of newer elektrons on the old silver boxes. The Dev’s that published the unofficial firmware are also the ones that develop the megacommand. If you are into individual track lenght’s, tracker-style pattern management, extended midi sequencing, some new mixing options and much more you should look into the elektronauts thread regarding the MCL:

There also should be a link to the dedicated discord regarding MD.X and the MC

1 Like

Check your global settings! Maybe your program change is off or diferrent base channel

1 Like

I used to have a MIDI Solutions Quadra Thru, but it wasn’t reliable and didn’t work for my use case.

The Quadra Thru is a passive (unpowered) device, and how it performs will depend on what you have plugged into it. Some devices don’t have sufficient power available from the MIDI out jack to be able to drive four additional MIDI devices. The manufacturer doesn’t warn customers that the device does not conform to the standard MIDI specification and may not work properly in all instances.

I used my Quadra Thru with an Octatrack, not my Machinedrum, so I can’t guarantee that this is the problem, but I very strongly suspect it is. To troubleshoot, I’d remove the Quadra Thru from your MIDI chain, and try connecting the MD directly to each synth, to see if they each work as normal without the unpowered thru box.

I’ve switched to a powered MIDI thru box, and no longer have MIDI issues.

Good luck! It can be a pain testing and troubleshooting…


Man this forum is amazing, thanks for the help i haven’t thought of this that way, it was indeed the quadra thru, it works flawlessly when the signal is not coming from the thru box.
Thanks a lot! Now i gotta squirrel some money away for an active midi compliant thru box.
Never encountered this problem before as my main sequencer was an MPC…

1 Like