Brand new RYTM -- boots to blank screen


#1

Hi everyone -

I just got my RYTM tonight and plugged it in and the screen lights up but stays blank until I hit the first trig button. Other buttons seem to not have any effect when the screen is blank.

When it does boot it shows 1.02 for the OS.

It does this every time I try to turn it on. Any thoughts on what it could be or what I should try?

Thanks!


Rytm MKII reliabilty
New Rytm, blank screen. Help?
#2

What does it do if you hold FUNCTION while turning it on?


#3

Brings up the “RYTM” menu.

BTW: I tried the PSU from my A4 since it’s the same model and it has the same issue with either power supply.

EDIT: I have now tried the test mode which passes and a factory reset to no avail.


#4

Tried loading the latest OS again.

Some weirdness. When booting with the function key held and trying to send the .syx file, the C6 Utility did not see the USB port on the Elektron so I had to use the MIDI port. The OS was received fine, but there’s no change in behavior on boot.

The USB port shows up in the C6 Utility once the machine is booted, just not in the early startup menu.

I opened a support ticket and was told that someone from Elektron U.S. would be contacting me. Anyone here have any experience with how long it takes for them to contact you once Sweden tells them to do so? I’m going out of town at the end of next week so I’m hoping I can get this sorted before.

Also, I ordered direct from Sweden. Wouldn’t I have to ship back to them anyway?

Any guidance would be most greatly appreciated. I’m so bummed that I waited so long for my pre-order and finally ordered direct only to get a RYTM that isn’t working correctly.

I do wonder if something came loose inside during transit?


#5

This symptom just actually occurred to me this past week. I thought I was hosed and started filing a support ticket with Elektron and hooking up with the store from where I had purchased.

I was able to solve by powering on with the function key pressed (previously I had powered on and tried holding trig 1 or trig 4 and that was the incorrect step).

From there, I tried the OS upgrade. The RYTM through my USB port was not being recognized by my Mac. So, instead, i opted the MIDI cable route to upload the latest RYTM OS to. Plugged a midi cable in the MIDI OUT of my 8 port Edirol UM-880 Interface patched into the MIDI IN of the RYTM. Pressed the button on the RYTM to start the OS transfer and then fired away on the sysex librarion app on the correct MIDI port on my interface that I was using (port 1). Some time later, the OS upload completed and the machine rebooted. I had a fully working RYTM again.

I’m not sure as to how the RYTM got into this state as I had successfully uploaded each OS on each new release without issue and then using the machine for a bit thereafter. It just turned out that I was working on another project (building a Shruthi XT at my desk) and the RYTM had been OFF for a few weeks. When the latest OS was released 1.02D at the time, I grabbed and power on the device and this is when I noticed that the device was Frozen on the startup screen with Logo, the letter C on the lower right and the OS REV of the time 1.02C.

Just happy I was able to restore and no data of any sort was lost.


#6

I’m glad that sending the OS worked for you.

I’ve been contacted by U.S. repair for Elektron and that’s what they suggested I try.

Maybe I should try it one more time?


#7

Okay. I was told by the repair person that I would have to send my RYTM in for repair and I would have to pay for shipping back and forth and it would take 2-4 weeks. Is this how Elektron operates? A brand new unit from Sweden isn’t functioning correctly and they can’t just replace it and pay for shipping?

In some more weirdness, after sending 1.02D to the RYTM it was still having issues. I left it unplugged for an hour while I went to lunch. Upon hearing that it would take weeks to get a working RYTM if I sent it for repair, I was going to try sending the OS again. I turned on the RYTM and now it boots fine. Every time I’ve tried it.

I don’t get it. I’m hoping that this is it and it just continues to work!

Thanks for everyone’s suggestions. I’ll report back if it starts acting up again…


#8

Is there a way to check which OS you’re on besides the quick flash on booting?


#9

@natallica

DId they ever tell you what was actually wrong with your rytm. I have the same problem and nothing seems to work. I get stuck over and over again, after factory reset, after empty reset and also after up,- and or downgrading to another OS via MIDI- DIN and C6.

Opened a ticket but support was not really able to help.