Blofeld Global settings Problem

I Was hoping to find other Blofeld users on here who are having the same problem as me. When I start up the Synth my global setting are not being saved and ever time i have to set local control to ON and the midi Channel ECT. I think it might be a Rom or battery issue. Other wise the unit is fully functional and saving presets work. Anybody care to offer up Advice?

mm, never had such issue. which OS are you running?
i don’t recall having seen a battery on the board

I am running OS V1.23. Every time I turn the unit on its Local control is set to off. Kind of Frustrated.

i just tried on mine and the Local setting is stored no problem. you mention you’re running OS 1.23, on Waldorf’s website the latest firmware is 1.22 :astonished: where did you get that one? :slight_smile: (did i miss a release? :sob: )
if that’s the OS you’re running, perhaps there’s a setting somewhere that stores the Local parameter…

I received that OS via an email from customer support.
I believe it was to address the encoder problems that my unit had developed.
It’s dated Sept 2014 and the encoders work better after installing it.
I can try and track it down if you want.

I think the problem has something to do with the Flash ROM in my unit since
every time to turn on the unit its stuck on Midi channel 9 and Local off.
Which is how I used to set up the unit when using my MonoMachine.
Now its stuck on this setting and I have to enter the global menu and turn local on every time before I can play. If you change any setting they will not remain once the unit is powered off. Kind of a pain.

I dont use Multi Mode on my Blofeld. This problem is something else.

@Noby may I advise to report your problem to Waldorf ?
I wouldn’t like to get this pb of yours after next firmware update :wink:

FYI, I just checked mine (desktop). I have 1.23. I don’t remember where I got it from. I do not have the same problem as the OP though. MIDI channel and other global settings have always worked fine for me.

And I doubt it is a battery. I don’t think Waldorf uses batteries.

I’m also not having this issue and I’m on 1.23

Thanks guys, I really appreciate the Feedback.
My unit is an Early KB version and I think they were not built as good as the more recent ones I have seen in the shops.

I might get in touch with tech support again but this unit is way past warranty so not much I can do I’m pretty convinced it is in the units Flash memory. What a sad situation for a die hard Waldorf fan like myself.
I really love the interface and modulation possibilities.

1 Like

Hello, did you solved this issue?
Best regards

I Did not find a solution so my Blofeld has been leaning up against the wall collecting dust.

Thank you for your answer.
But I do not understand…the blofeld does not work??? or only need to change to local ON every time you power on the unit?
best regards

The Blofeld works Perfectly but I cannot save the global settings such as midi channel and local on/off. Every time I restart the blofeld it reverts back to it`s older settings. Also I think this includes multi part setups too which I can no longer save. Probably an internal memory issue. I Gave up trying to fix it. I thought about selling it but with this glitch it would not sell for very much. I picked up a Microwave XT rack so I’m not to worried. I will use it again some day. I can still save regular presets and I do like the keyboard itself.

Did you try to remove the battery to “clean” the memory and install the firmware again?
Did you contact to Waldorf to solve it?

I don`t think I will try re installing any of the Firmware in fear it might cause further problems. There is always a risk of it getting corrupted.
I will try looking into the battery solution. I didn’t think it had one when I last checked. Good idea though.

Hello Noby,

My Blofeld has the same Nand memory problems as your Blofeld. I can not save Multis or Global settings wich are stuck. Have you solved it?

I have not resolved the issue. I didn’t have luck contacting Waldorf. Let me know if you find out anything. I am pretty sure I tried firmware but with no luck

Waldorf said that NAND memory must be changed for this.

Good to know. Sounds like something hard to do yourself.