AR as a soundcard


#1

Hi guys,

I am going on a short vacation and wondered how I should configure my Ableton and Analog Rytm in order to get my softsynts from Live feeded into my AR in order to hear them through my headphone connected to the AR.

So basically what I want is make a beat in AR, record this on an audio track in Live and then record a softsynth in Live and hear everything togheter on my headphone connected to the AR.

Should be possible right?


#2

It is possible, right.


#3

I just discovered it is…


#4

yes, certainly. through overbridge, you can use the rytm as an 8 channel mono mixer with multimode filters and overdrive for every channel.

Set up the rytm as your soundcard output in ableton. Then, assign the output of any audio tracks to the rytm channels. You can hear the audio thru the rytm if you trig a track once which has an audio assignment on it from ableton.

for this to work in stereo, you need to use two rytm voices for each stereo track. But this way, controlling the filter and overdrive parameters can become slightly clunky, although you can use page copy/paste functions for duplicating the settings to the second voice.

Does this make sense?


#5

I´d try this before going on vacation without an audio interface. I had the same idea but unfortunately my AR stopped working at all (not responding to anything over overbridge) when I set it up as audiocard. I was also connecting an AK and Push2 on my MBP (i5 with OSX 12.10.4) and the latest version of Live and Overbridge. I´d love to see this working, it would save me carrying the MOTU ultralite mk3 with me on gigs. But at the moment it´s too unreliable for me. Great to see another 100Euro extra charge for this software in the future.


#6

I guess a power consumption problem was responsible for that. The MBP ports are tricky if you slightly exceeded the bus power…


#7

Well I was using a powered hub. Maybe it only works with the magic Elektron hub (which comes without a power supply).


#8

I tried it again today and failed. I read the manual but I either missed something important or the configuration is not expected to work. Here is my setup: I want to use the AR as audio interface. No other USB devices are connected. I set the AR as audio device in Ableton and when I enable “Output to Analog Rytm Main L / R” in overbridge I hear Ableton´s output on the Main outputs of my AR. In a next step I load the AR as a Plugin in Ableton. The sound of the AR is now doubled because it´s coming out the analog main out and out of Ableton as well. How can I mute the analog output of the AR? I always add some FX in Ableton and use a separate track for the Kickdrum, so I need to do the routing in Ableton.

Step three would be the Audio input. I don´t see a channel for that in the Overbridge Control Panel. Please don´t tell me that there is none!


#9

You need to disable AR’s main outs in OB’s control panel. The Input must be the same as on A4-OB, I admit I have no experience with the AR as a soundcard. Usually all IN-and Out’s provided from an interface were seen in Ableton’s audio setup - as they were assigned in OB’s control panel.


#10

There are many ways to use overbridge. One way is to use it as an audiointerface only, in which case you select it as your audio card in ableton settings (do not mess with the overbridge ctrl panel in this scenario!). Another is to use the AU/VST plugins of overbridge, and route the audio from the plugins (this is the scenario where you use the ob ctrl panel). If you are using both methods simultaneously, things will get very confusing very fast, and might not even work as expected.

Not sure if this is how elektron also sees is, but IME do not mix these use scenarios together. Use only one or the other.


#11

Disableing the Main Out is the only way to use the AR / A4 as a soundcard? I am speechless. Let me get this straight: No one at Elektron thought that it might be a nice thing to bring a laptop and an Analog Rytm to a gig and use it as in instrument and as an audio interface at the same time? And who the hell buys an 1600€ drum machine to ONLY use it as an audio interface without the functionality of the instrument itself? Again, I am speechless.


#12

That is surely NOT what I’ve said.

I was trying to solve a problem step by step.


#13

It’s been a minute but I’m pretty sure your just disabling the direct analog output from the main outs, you’d then monitor your AR signal through the daw and it would appear back at those outs mixed with whatever else your sending from the daw…


#15

Right! :grin:


#16

That was my first idea as well. But as I see it there is no way to mute the direct analog out and enable the AR signal in a DAW. It´s either on or off on for both the analog and digital/overbridge outputs. I am sure that this is no technical restriction since it is possible to workaround this issue by using ALL single outs in Overbridge. But that blows my CPU and USB bus and I only want the AR on one channel and not eight.


#18

Any news? I tried your configuration with the same result: the signal is either on both outputs at the same time or on none of them. Running the AR audio only on Overbridge and not on the analog output seems not to be on the feature-list.


#19

Thought I’d get to the lab yesterday but it didn’t happen, probably be a few days now… :confused:
Anyone else got some info about AR as soundcard without doubling the analog audio output?


#20

I’ve test the setup with an AR as a soundcard. It works as expected and the doubling problem is an issue of Live’s monitoring. It needs to be disabled (=OFF). Wether OB routing nor AR routing affect the main out (on headphone - I did’nt test the physical main outs, they should behave similar)

Only one issue remains, incoming audio is greyed out on the specific OB-audio-channel, but recording ist possible.


#21

This is giving me a headache aswell.

From what i understand, the only way to have the rytm mk1 as audio device with ableton live without doubling the rytms outputs is to select 4 channels of ins (eg bd, sd, rs/cp and bt + two outs “main left and right,” disable all the “send to main” and “send to fx” tracks on the rytm. Then use the vst plus audio channels in live.

But this means there is no way to record the main out of rytm. So no compressor or distortion, and only use four channels?

Its confusing, so please help if you can.