[answers - inline] Arming a one-shot doesn't work with my thru machine when recorder is not active

Hello,

The short version is this: I’m using a recorder on a thru track with a one-shot trigger.
I am trying to arm the trigger for recording but i’m unclear how to do this without having the recording page opened for one track at a time. I had expected the “arm track” would arm any/all tracks for record regardless of what track and/or having the recording settings open.

Here is what i’m looking to accomplish:

  1. I have my Digitakt doing drums (and a few other things)
  2. I’ve added in an Octatrack MkII so I can do some more with slicing, scenes, and other goodness of the OT MKII.

My goal is to allow the Thru Track to record the from the Digitakt so I can have that recorded and then switch parts to use a flex machine on the same track. Then go back to the part 1 (rec setup), do some more recording, and go back to part 2 (mangle) and mangle the audio… and then… continue to. rinse and repeat as I go.

I found several videos walking through this and frankly I’m stuck when it comes to the re-arming of the recording track.

My setup (on a new project)

  1. Inputs A,B are coming in from the Digitakt

  2. T1 is a Thru Machine

  3. The recorder page 1 is set to:
    a) INAB set to ‘A (space) B’
    b) INCD set to ‘-’
    c) RLEN = 16
    d) TRIG = “One”
    e) SRC3 = ‘-’
    f) Loop = “on”

  4. The recorder page 2 is set to:
    a) FIN = 0.063
    great feedback, use the ATC param vs FIN see other replies for more info
    b) FOUT = 0.063
    c) AB = 0
    d) QREC = “off”
    e) QPL = “off”
    f) CD = 0

  5. My main SRC for the thru track (T1) is set:
    a) INAB = ‘A B’
    b) Volume = “0” (no change on inbound audio level)
    c) INCD = ‘-’

  6. AMP are all default settings

  7. LFO - is doing nothing

  8. All FX are set to ‘none’

  9. I am in grid recording mode

  10. The active display is set to “Recording 1 setup 1”

  11. I press the FUNC + T1 (first sequence button)… I get the “one shot recording trigger”

  12. At this point I double tap the stop button it clears everything…

  13. I press play - the track symbol for T1 goes from square (stop) to ‘+’ for recording and after the first 16 steps got to the play symbol.
    So far, so good! - I have audio now in the recoding buffer - yeah!

  14. With the recording window still showing the display for T1 I can press the “arm” (or yes button) and boom… when it comes back around to the first trigger where I have the one shot setup - yeah, it records… sweet! (and does so as i’d expect, start on 1, end on 16).

  15. I close the “recording 1 setup1” page. by pressing FUNC + REC1

  16. I press the “Yes” or “Arm” button and I see “ARM TRK”

Here is where I don’t understand what is going…
This is where I needed use the help.

My initial problem
15) NOTHING RECORDS - I don’t get the ‘+’ symbol showing recording… nothing at all happens.
My expectation is that it would ARM the recording on all tracks that have the one-shot setup.
But, that doesn’t happen.

I am missing to make this work?
Here is what I found out
A) Turn OFF grid recording mode (record light is not lit)
B) Press the “Yes”/“Arm” button and now recording will happen

Any and all help here would be appreciated.

Thanks,
Brett

P.S.
Note: I want to be able to do this for more than one track…
I plan to setup T2 as well to record some other synth lines from an external source…
So being able to ARM tracks for record so that it can happen across several would be idea.
Moreover, I don’t want to have to go into the recording page for each track when I want to arm something to be recorded.

You could do it from an external device, like a foot controller or sth like a launchcontrol or remoteSL zero.
I do it on my Oktakontrol for several tracks at once, cool feature.

Here you find a lot of info on that topic.

3 Likes

I thought it was possible to arm One Shot Rec Trigs in Track mode but apparently only Arm all works, even with other machines.

Workaround : Use TRACK+ REC and QREC set to PLEN (pattern length) if you want to record at the beginning of the pattern. ONE2 mode to stop recording.
Or midi as @Augenadler mentioned.

I don’t use FIN and FOUT, especially because FOUT increase sample length, except with Pickups. I’d rather use Attack = 1.

1 Like

Hey All,

Great info - thank you.

One thing I did last night was also update to the latest OS… I was one rev behind.

Here is what else I found out:

  1. If I use Track + Arm it will are that track single track for record - that was cool.
  2. If I am NOT in grid recording mode and I arm the tracks - it looks like the record will be armed.
  3. if I am IN grid recording mode and I arm the tracks - It only triggers the non recording tracks

It is rather subtle in how that works but I suspect that makes some sense, if you are working on recording and you arm all track you may not want what you are doing impacting the track you are work on at that time… maybe… BUT… the upside is - I now have several new ways in thinking about how I can record and when.

Thank you for the tip on the external controller as well - I’ve been thinking about that but it then is also yet another thing I need to bring but at the same time super useful. I suspect i’ll end up picking one up soon.

Thank you all for the help.
Brett

Just FYI the recorders aren’t attached to tracks so it’s not actually the thru track that’s sampling, the recorder of that track number will work the same no matter what machine is assigned to it. Also since you have your recorder set to A B, it’s sampling the inputs and not the thru track. Your sample will be the sound entering the inputs without any fx or anything from the thru track. Sampling the thru track complete with fx would be setting the recorder SRC3 to the track number of the thru track.

If your not using the thru track fx you can instead monitor using the mixer direct and save a track. If you like you can have a flex already set up to play the recorder buffer so after you sample your new sample is already looping, use the fader and scenes to have it muted at first and your able to fade over to it and also have your mixer signal fade out at the same time. You can have the same recorder buffer loaded to multiple flex tracks if you want. You might not need to use other parts as it’s possible to live sample, loop, and warp all within one part…

All the one shot arming/disarming behaviors are outlined in the manual section 12.4.5 One Shot Trigs…

3 Likes

@Open_Mike - thanks!

  1. Thank you for the clarification on the thru track and sampling that because:
    a) I wanted to add effects and record the effects from the through track (this is why I was picking it).
    b) I’ll adjust it to the sources as you suggest - super useful thank you!

  2. I do understand that most of this is outlined in the manual but I have to say - I work in the tech industry and their are two types of manuals in the world. One that it is technically accurate and just tells you how everything works (most tech manuals in the world, and this document is no different)… and there are manuals that are more scenario based (only a little bit of that in this manual) that takes you through the step-by-step of everything in context of working through a scenario. It is the later part that i’m trying to build out and end-to-end understanding. And to that end — I really appreciate the insights you have here for ways to record AND have the fx and how yet another piece of the end-to-end puzzle is coming together. I will go back and read through it again for sure and see if reading it again will help fill in more missing pieces. :slight_smile:

Thank you for the feedback, I greatly appreciate your time and help.

Brett

1 Like

Yeah the manual is pretty dry tech reference without use cases, but the arming/disarming of one shots section is pretty clear. Not trying to give a RTFM more like a “hey check that part out again, it’s in there…” :smile:

If your going to sample the thru track make sure to disable the input selection of the recorder and only use Src3… With both selected it would sum them together…

2 Likes

Oh Dude!!!
That works like a champ!

Thank you for the help… i’m trying this out as I read the above.
This is exactly what I was looking to make happen.

Thank you.
This is GREAT!!!

Brett

1 Like