Analog Rytm OS 1.45: bug discussion


#104

About that latching mute state change function that was removed in this OS version, seems like the latching still exists in some form. I was going through some more of my old projects today, and messing with func + pads sometimes created a latching state… However I am unable to reliably replicate the latching?? I’ll see if I can figure out a way to get the mute states to latch in a way that is reproducible. Lets hope it can still be done somehow!


#105

+1


#106

Are you not just muting the sound by playing a pad and as a result overriding the sequencer?


#107

Nope. Talking about the undocumented ”mute state change latch” function which was removed in the latest OS.

On the older OS, one could dial in a batch of mute state changes by first pressing func + pad(s) in mute mode, making those mute tracks show a blue light. Then, with those still held, hitting the tempo button once ”latched” those blue lights, which would be held until pressing function once more.


#108

Does it still work when switching modes?

Still on old OS


#109

I am so sorry, I was not aware of that feature. I just recently discovered the “function+mute” which is awesome for live, but I never tried to latch that mode.


#110

That latching is great


#111

at least it was before the update…


#112

Does anyone have time to check this? Support can’t seem to reproduce it, but I’ve tried everything. All other devices (on older OS’) send clock fine via USB. Thanks!


#113

And you have enabled midi out to USB on the AR (global/midi config/port config)?


#114

I’m already back on the older OS so can’t confirm latch is gone but puuhhllleeaasseee put it back Elektron.

Unless there’s the same feature executed differently…


#115

:cry::cry::cry::cry::cry::cry::cry::cry::cry::cry::cry:
I updated my analog rytm mk1 to OS 1.45. It does not work now. It only shows the startup screen with elekton logo. In test mode it shows 0 errors. When I try to do a factory reset it returns to the screen with elektron logo. Also now, C6 cannot see the machine. I have already contacted support. Has anyone any idea about how to fix this or experienced similar issue? Thanks.
:cry::cry::cry::cry::cry::cry::cry::cry::cry::cry::cry:


#116

you could try and downgrade to a previous version of the OS? maybe that would help and at least you could use your AR again?


#117

I cannot downgrade, C6 cannot see it. They have contacted me from support and it needs to go for service.


#118

mm…you could try with any of the options suggested in this thread…if not, well…service it is then :expressionless:


#119

I am pondering the cost/benefit of taking the plunge and wondering if there is/could be a definitive list of replicated bugs. Maybe updated to the OP’s OP? Very stoked to check out the Dual VCO! …also terrified of bricking my Rytm as above…!


#120

Have this bug too


#121

Not sure if this is new to this OS update – when I double-click on the ‘Synth/Delay’ button to open the synthesis engine page to assign an engine to a track, the encoders still update values associated with their parameters even though they are not visible on the OLED screen.

This sort of makes it difficult to notice if you’ve changed values from accidentally bumping an encoder or turning one by mistake to try and scroll through and select a synthesis engine (even though you do so by using the up/down arrow keys).

If you’re on the Sample page and you double-click the sample/reverb button to get into the assign a sample tab and turn an encoder, then it immediately shuffles you back to the sample page where you can see the encoder value you changed update.


#122

sooo guys, it is worth the upgrade with this bugs? specially if you are doing gigs often?

or better wait the bug fixes?

thanks


#123

Also not sure if this is related to 1.45 OS , but when I try to assign a perf lock to the sample loop parameter (should just be 0 - off or 1 - on) I am allowed to assigned the parameter to a value between -128 and +127.

EDIT: same with perf locking the sample file parameter. There are only 0 to 127 sample slots, yet I am allowed to perf lock the sample parameter to a value between -128 and +127.

EDIT #2: same with perf locking LFO mod destinations. I can scroll through the destinations when I try to perf lock to a LFO mod destination, but they just end up being represented as values on the performance track rather than the name of the destination. Also the encoder values represented in the perf lock are wonky, as there aren’t -128 to +127 perf destinations.