Analog Rytm MkII – Logic Pro X/Overbridge 2.0.37 Template here

Not to my knowledge but I’ve never owned a MkI :slight_smile:

In the MkI’s Audio Routing, if the channels are sending to FX (check it’s not 0/12), the FX should come out on the master channel – which the template labels as FX.

I’ve tested and used these with 2.0.37, and they don’t need changes, so the 2.0.31 file here will work fine (I just can’t be bothered to change the name)

Hi @rgarner - thanks again for this, really helped me when working through my own logic/overbridge setup. I’m curious if you’ve seen how I have it working here: OB and Logic X - Setups Detailed

Do you happen to have any solutions to the issue of only being able to record midi to one track at a time? Also, I remain wholeheartedly confused over what would be the use for the fx track, though I’m sure it could be made to be useful for something :thinking:

Russell, thanks, it was so helpful. I’ve lost many hours to fiddling around and getting something working in Logic, only to return to it (after another round of updates) and find it broken —this is great!

1 Like

Really happy it helped, strongly appreciate the kind words.

I’m not sure what you mean – I only ever record MIDI to the single plugin track? I only have a Rytm MkII though, not an A4.

As for the FX track – yes! It’s the main track, or inputs 1-2. It only becomes an “FX” track for me when I stop routing audio from tracks 1-12 to main via the Audio Routing menu. At that point it carries only the audio from the reverb and delay. Since nothing is going to the main distortion or compressor, those are effectively disabled at this point. I call the track “FX” in this template because I’m assuming you’re recording multi-track with FX sent to 1-2, and muting it makes the signal entirely dry.

I meant the fx track that shows up as you keep hitting the + button, the track channels all show up as aux and then one more which I can only assume is the “fx” track. I realize the actual fx come through on the main channel, so wondering what this extra aux track is for.

Afa recording midi, yeah, you can record to the main track and then separate by channel, or iirc delete the region and it will ask if you want to separate them or something, but it would be nice if you didn’t have to go through this extra step. Workflow hassle especially if you want to do different takes or overdub midi, things like that.

I can only speak to the Rytm, but when you do a Multi-output (10xMono), as these templates are, you can add 9 tracks via the multi-output plugin with the little +, from BD all the way to CB with the three ‘shared’ tracks RS/CP, CH/OH and CY/CB (See below, I think you found a bug in my template, so thank you!). The output on the plugin track itself is the master out, and if you’ve turned off routing to master for the other channels, consists at that point of the FX only. In these templates I bus that master out on Bus 10 and add a track for it to sit alongside the other tracks under the Rytm Buss stack, so it all sums back to Bus 1.

So the last track when you hit the + for the Rytm is CB (this is a bug), the FX is on the main plugin out.

You can see that in this screenshot (the + is greyed out so no more can be added):

EDIT: I think I’ve just noticed what you mean – this template has a bug! CY and CB should be shared. I don’t think that virtual Analo10 bus produces any sound and I don’t think the plugin should allow you to add it. The FX come through the plugin track, but in this screenshot I’ve wired both the plugin track and the last track (erroneously named CB) to Bus 10 so you wouldn’t notice a difference. Going to check this and get back to you… thanks again

EDIT2: @kalin yep, like you, I assumed that last track was FX and was mystified when I couldn’t get any sound out of it. Eventually, I realised FX was basically the plugin track itself without audio routing (and wired it to FX bus 10), but I forgot to take out the last zombie track (which was also redundantly wired to bus 10) and my labelling on the last two tracks was messed up and didn’t acknowledge that CY/CB was shared. Fixing the template and re-uploading now.


Ok, I’ve updated the template, tested with 2.0.37. I’ve renamed the last 10xMono output aux track unused and set it to no output. This has the effect of leaving the + button on the multi-out greyed out. As far as I can tell, this track shouldn’t be a thing you can add, but since it is, let’s reduce confusion by naming it and making it visibly not do a thing:

EDIT: this unused track is actually stereo audio in from the sampling inputs, and definitely does do a thing…

Thanks @kalin for what turned out to be a really useful bug report :slight_smile:


With respect to the recording multiple MIDI channels at once, I don’t see how this relates to the AR so much but you have an A4 and you might be talking about a problem I had with my Sub 37 and Prologue – how to record both at the same time. The answer for me was an obscure checkbox in File > Project Settings > Recording called “Auto demix by channel if multitrack recording”.

This setting allowed me to put the Sub 37 on Ch1 (both in its own internal settings and on the Logic Track settings) and the Prologue on Ch2 (again, both in its own internal settings and on the Logic track settings). Then recording both at the same time would appear to go only to one of those tracks but on stopping recording would auto-split the region across the tracks. Hope this is the thing you’re missing for the A4?


Ah, yes I’ve seen about the “auto demix by channel” - this wasn’t the issue. The problem is that with the elektron plugins, the individual tracks are all sub tracks of the main aux track, so don’t have their own record buttons.

It’s as much a problem with the AR for me - if I’m using samples and want to do another take of just the sample tracks, leaving the drums alone, or vice versa, it’s just really messy to not be able to record the separate midi directly to separate tracks. I know it’s possible to work around it, and it’s not Elektron’s fault it’s Logic’s, as you can easily do this in Ableton, iirc.

In any case glad to have some dialogue about it, always nice to know people are working out the same technical problems that you are struggling with :slight_smile:

I think I see what you mean now. I guess you’re using chromatic mode? I suppose I’ve been using the Rytm as a fairly simple drum machine and moving and automating samples in-DAW as a separate thing. I have been irritated by the default MIDI that gets output because of the non-chromatic nature of what I’ve recorded – it has tended to be all in one line in the piano roll. I’ve started to record the auto-channel (channel 14) instead of individual channels so that at least each pad can be on a separate line in piano roll.

I’m not completely convinced with Overbridge if I’m honest. I bought a Clarett OctoPre so that I could play the pads live with less latency than the Overbridge plugin could afford but it seems the plugin always compensates for USB latency and doesn’t work well for the multi-outs. This reduces me to using the External MIDI control and audio tracks, so often I don’t or can’t use the plugin.

1 Like

Exactly. Don’t get me wrong though, I think overbridge is great for some things. It’s just frustrating, like with any software, when you incorporate it into your workflow, and then come across a problem where it’s not acting as you would hope or expect, this forcing you to re-evaluate your workflow, spend time troubleshooting or looking for workarounds etc. Such is life in the world of music tech!

1 Like

Hey y’all. So Im looking for some help with Logic and overbridge here. Got everything setup and working fine as OP suggested. Only thing is I cant get the AR to receive transport start/stop messages. I go to midi>sync>midi project sync settings and can choose it there but its not working. My other hardware is receiving fine over mid. Pretty sure i have everything set right in the AR… any ideas?

@emptyvesselband if you’re using the plugin, that should take care of sync. Not only do you not need to use Logic’s own MIDI Sync from preferences but it could interfere, so turn it off. The plugin should handle transport and sync all by itself.

That said I’ve never only ever had intermittent transport issues when both are on – sounds like you have a different problem. I know it’s a cheesy suggestion but: tried another cable?

Quietly fixed a fix to my fix: when I made the unused track before with No Output I accidentally set Rytm Buss to No Output also. Have set it back to Stereo Out.

Thank you very much for your template.

I just inspired from it to make my own, it helps a lot though.
Only using transport and pattern changes and evrything works well so far.

I didn’t read the full tread, I’m wondering, is the ninth channel it made by clicking on the + icon the stereo input ?
I only got the AR MKII for 3 days so didn’t used the input yet.

By the way how do you get this lovely AR MKII icon in Logic ?

Find a nice PNG from Google Image Search (with a nice transparent background). Right click the track image. Go to custom icons, click +, find your PNG, save your template :slight_smile:

Thanks, very classy

Sorry to anyone using these, but 10xMono was removed in a recent Overbridge release. This is pretty annoying, as it’s broken any project that used them and also broken this template. I’ll upload a new one later with the remaining 10xStereo.

To Elektron: what were you thinking? I have dozens of projects with either the 10xMono or the straightforward Mono plugin all using Total Recall. Total Recall is now Total Amnesia in these cases, as I can no longer get these settings back. This is a breaking change that breaks a year’s worth of projects. WHY?

It’s not as if 10xStereo even makes any sense, as you can’t pan within these channels.