Analog Keys Not Sending Midi

I’m using the AK in “Overbridge Mode” in Logic Pro X, I can play the keyboard but the AK is not sending notes to Logic, so I can’t record Midi . I have re installed Overbridge, latests updates etc. I checked on different settings and I can’t make it work, any help much appreciated.
thx!
PS: OSX Mojave , latest Overbridge and AK OS 1.50A
S

Is KEYBOARD DST set to INT+EXT in the midi port config menu?
(== send notes to internal engine + midi)

Also check the OUTPUT TO setting in the same menu to include USB.

yes it’s set that way, Ive also done a factory reset . I do notice when I go to Global settings settings in the AK , System–Usb Configuration- Overbridge checked , and then check on the OSX Audio Midi set up, the AK is greyed out and when I change the Ak USB settings to USB Midi then it comes back online . The problem seems to be AK disconnects from the OSX Midi set up when on Overbridge mode

AFAIK when in Overbridge mode you also need to use the Overbridge plugin to get access to MIDI.

yes that’s what I’m doing

I can’t speak about Logic, but in Ableton you need to disable USB MIDI IN/OUT for the device managed by Overbridge in the preferences of Ableton itself (where you normally configure USB MIDI devices).

Otherwise the Overbridge plugin conflicts with the standard USB MIDI driver.

I just tried in Ableton Live 10 and same issue than with Logic, in fact the AK doesn’t even show as available in the Midi settings, which it makes me realise the issue is with OSX and the AK becoming un available when Overbridge mode is checked in the USB Config of the AK itself and hence not sending midi. Even without using the OB plug in the AK is disabled from OSX because it’s in Overbridge mode