Analog Four Mk2.. Track 2 is one tone lower? [resolved]


#1

Hi all

I’m going mad here - my Analog Four seems to have a permanent ‘transpose’ of one town down on track 2. I’ve tried it across all projects, I’ve recalibrated the unit, I’ve turned it on and off again.

Transpose is showing +0 (ie nothing happening), it happens on a brand new project with just the init sounds too (eg a G plays as a G on the init sound on T1, T3 & T4 but not on T2 where it plays as an F).

This is all just with local control ie using the keys on the front of the unit, but also triggering via MIDI (which I’ve tried) features the same offset.

What on earth is going on?!? Can anyone help please? It’s driving me mad!

Thanks

John


#2

Which OS? MKI/MKII?
No midi connection?
(OT sends CC48 and change fine tune).
Edit : this doesn’t change a tone but semi-tone max, and you tried standalone…

Was it working properly before?
Transposed even if you disable that track from transpose?

Did you try test mode?


#3

MKII and the latest (beta Overbridge) OS.

I have played around with it a bit more and if I do a hard reset then it does behave itself from startup. The problem seems to be triggered when Logic is record armed on an A4 track and I move the locator. I used to have this problem back before I’d isolated every other synth input on the Environment - now all CCs inputs from various synths are filtered unless I want to record fader / CC movements for example… but all my switches are off. It must be something that Logic is sending to the A4, probably via Overbridge as that’s the only connection, that’s pitching the active track down.

I do have a tempo map so perhaps that is having an effect?

It’s so random though and I have no real way of monitoring the MIDI stream between Logic, Overbridge and the A4.


#4

I can’t help with Logic and Overbridge.
Is the track 2 tune value set to - 2?


#5

No, absolutely everything on the A4 is normal… all tunings 0 or in octaves and whatever ‘master’ calibration Logic is sending to it is applying across all presets, even just the init in a fresh project. The only solution seems to be to do a hard reset every time it happens.

It’s not limited to T2 either but happens on whatever track is active, eg if I’m trying to record / play / audition T3 and have it record armed…

Eugh!


#6

Does the octave light (above the small KB) move around when you change tracks?


#7

Yep…


#8

Edit - I think I’ve found the problem. I’ve got a Deckard’s Dream synth and I hadn’t turned off the CC transmission (don’t get me started on Logic’s ludicrous system for managing MIDI inputs - akin to routing all audio inputs to all tracks by default and then putting the onus on the user to delve into the Environment and sort their mess out for them!).

God knows what CC or other code it’s spitting out though that causes such a random, and permanent, shift on the A4. It can’t be a MIDI cc as I’d see it reflected in the Tuning page on the OSC pages… Oh well, it’s a mystery, but at least I’ve managed to stop it happening.


#9

That’s normal behavior when you’ve set the mini KB octave differently on one track to another (the octave is set per track.)

Change the octave so that all tracks match, and you should be good to go.


#10

I don’t see why that would put one track one tone out from the others though? Octave, yes, but not tone? (i.e. two semitones). It also applies to incoming MIDI notes, not just those triggered from the on-board keyboard…


#11

Ah, I misunderstood, and thought it was an octave off.
My apologies.

I hope this Deckard’s CC transmission was indeed the issue, though, and that you’ve now sorted it out! :slight_smile:


#12

No problem, thanks for trying to help!

Honestly the whole thing could be avoided if Logic wasn’t such a nightmare with MIDI - a ‘professional’ MIDI sequencer that can’t even record and transmit Sysex messages properly, and sums all MIDI inputs by default to any active track… absolute nonsense!


#13

If it makes you feel any better, I nearly drove myself insane yesterday, wondering why notes and joystick actions played on my Analog Keys FX track was also controlling my Track 1 sound. And that it would ONLY happen with the USB connected to my DAW for Overbridge.

After a couple hours, I discovered it was a simple MIDI input setting in Ableton, receiving auto channel information from the AK and sending it back to Track 1.

I will try to remember, moving forward, to just strip out my DAWs hardware MIDI input assignments, and reintroduce them, one by one, the next time I have an issue I can’t troubleshoot in a more timely manner.


#14

Edit again - I don’t think it was the Deckard’s Dream as I just had a ‘hilarious’ moment where all my studio synths were told (by Logic I assume) to go to various random pitches… that was one of the worst sounds I’ve ever heard! Deary me. Ok well this has long since ceased to be an Elektron problem but just leaving it out here in case anyone arrives from the Google future…