Analog Four MK2 boot issues


#1

Hi everyone,

earlier the day i was turning my analog four mk2 on to see which firmware it was running, but missed the boot screen where it is said, so i turned it off again while it still showed our favorite company’s brand logo.
i flipped the switch on again, but heart attack, nothing to see or to hear except a little popping sound when flipping the switch… tried it again and again - no signs of life.
this almost made me cry - did i break this gift from heaven just by such a little mistake?!

took out the power cord, flipped the switch a few times more, connected everything - nothing.
left it for a few minutes powered off and unwired. - nothing.
maybe the power supply blew?! - tried the one of my rytm - nothing. (power supply of A4 let the rytm power off immediatly)

it was to that point i almost s**t my heart on the carpet, suicidal thoughts surrounded me. this just could not be true.

i unwired the device completely (almost packing it to send it to my reseller for warranty), switched the power to “on” and left it sitting on the desk for like 5 minutes.
i said to myself to try it one more time before i wanted to contact the reseller.
wired everything again, crossed my fingers, bit my lips, closed my eyes and flipped the switch - a pop sound was audible… opened my eyes - there it was in all its shiny beauty, as nothing ever happened…

i jumped around full of joy - my baby was back.


BUT :
since this happened, i feel like i can not “trust” the machine anymore… i’m really scared this was the beginning of worse to happen, i imagined it to happen right before a gig…

how can this happen just by such a simple mistake (which i assume is done pretty often without having this result?) was it something like a RAM issue?

did anyone of you experienced something similiar? how do you cope with your machines acting strange?
am i just to squeamish and should act more like an adult?

looking forward for answers, experiences and opinions!

-rawghy


#2

I have no idea but I imagine it was just some glitch caused by powering down before completing power up, I doubt it’s a actual hardware fault but I’d send a ticket to support if you want to put your mind at ease.

If you perform an “Empty Reset” it will wipe and reinitiallize the devices RAM, leaving the +Drive intact. You do this by holding function when powering up, and then pressing trig 2 after the Test Mode screen comes up. If you need to save your active project I’d probably save it to new just in case something got wonked with it then you’ll still have the last saved version to go back to, or if your not worried about it just don’t save it…

After the empty reset you’ll have a new initialized RAM state and should be good to go…


#3

I think this is normal behaviour. The (analogue) circuit might need some time to properly discharge after. I recall reading something in Digitakt manual to let the machine sit for a while before attempting to turn it back on. Nothing to worry about :smiley:


#4

I’ve encountered multiple products that can have trouble with too fast power on-off cycles. Some even specifically say not to flip switch within some interval from the last time.

A lot of these issues can relate to the state of the charge on internal capacitors, where turning it on might reset them to the bad state, and the only way to revert it to normal is to wait some time to let them fully discharge. (which might take an appreciable time).

That said, I’ve only encountered one weird niche device that could suffer permanent damage from this sort of case… so that’s good


#5

Got my A4 shortly after new years eve… It was pretty cold (because of transport) so i did let it rest for a few hours.
Well, then i was as excited as a small child to turn it on the first time. Then like you, heart attack!, it didnt boot. I turned it on and off a few times, plugged it into another socket, nothing, except once it showed up the elektron logo for like 1 sec.
I sent it back to the reseller and 2 weeks later i got another new A4.
But since then i’m always kind of shivering while it’s booting.
But i think, i just had bad luck with my first A4.
Wish you all the best, for not getting boot problems ever again. :wink:


#6

Yes the Digitakt will do that if you power it off and on too quickly. You just have to give it a little time


#7

Thank you all for your responses!

i really think it has been a RAM issue. as a computer technician, this kind of behaviour is quite similiar with RAM problems f.e. on macbooks, which can be solved by disconnecting the battery for a while or doing a manual RAM reset.

interesting there are methods on the elektrons for ram resets as well! i did not know that!


#8

Certain capacitors need to discharge before they can turn on again. I know this goes for the Digitakt and it wouldn’t surprise me if it applies to other Elektron boxes. Not sure if ram has anything to do with it. Also how do you reset ram? It is reset as soon as power has been removed. On a Mac you can reset the smc and nvram to sort out (weird) problems. Never heard of resetting the ram.


#9

The Elektron machines use nvram (there is no load project phase when you turn it on). The build-in “memory reset” function simply clears the nvram and opens the load project screen.

And, no, I also don’t think this capacitor discharging problem has anything to do with ram, because it prevents the device even from the first bootstrapping phases. RAM is normally checked much later.

Another trick you can try when it happens is to remove the power chord and toggle the power button on and off again. On some devices this discharges internal capacitors way faster/instantly (no need to wait).


#10

that’s what i meant. did not want to go that deep here, but you are right.
but of course it could be possible those capacitors are giving power on the ram even when the cord is disconnected. as i said, i am a computer technician and not so much into electrics itself. :wink:


#11

you are right, if it was the ram, probably it would turn on (in terms of at least lighting the screen or something) but doing other weird stuff instead of not doing anything at all!


#12

interesting input here! thank you all very much!
i think i can “trust” my a4 now a little more again :wink:

hope i never experience something like this again, but if i do, i will keep cool a little longer!