Analog Four/Keys OS 1.40: bug reports

I agree this is quite disappointing and problematic especially for people who want to live record during a performance for example. For the rest of us it’s just really bad for workflow.
Using a MIDI merger as @sezare56 suggests is a good idea. If I’m understanding - this will allow you to both hear the sound and record into sequencer at same time with the auto channel, but you’re out of luck if you need thru for something else.
edit: this is only true if you set your auto channel and track channel the same, and your external synth to that channel - not ideal!

2 Likes

You don’t set the auto channel as the track channel though. You must use the track channel to externally step program.

Let’s not confuse missing functionality with solutions predicated on extra gear . There is a clear divergence with how proper Auto channel support is implemented. The new midi possibilities reveal this as lacking.

To program you have to play blind. The best workaround is to use locks or the mini keys, but the price is sensitivity and comfort.

To me it makes no sense to not see this as missing functionality, but that is the official verdict. I think when people grasp this it will be so obvious that it is inconsistent and inconvenient. If you use external keys.

1 Like

Oh I see - because you’d have your external synth set to receive MIDI on the track channel - therefore wouldn’t hear it via the auto channel. I don’t want to sound ungrateful, but it’s like you said: given the purpose of the auto channel, this is definitely a bug imo, they can deny it all they want, but I believe it’s denials like this that steer people away from elektron. If they could explain WHY it doesn’t work like this, or WHY isn’t possible, maybe it would be easier to accept.

edit: ok, I am realizing why this may be technically “not a bug” - because the update promised midi sequencing via the sequencer, not a thorough upgrade of midi routing possibilities, however, I still can’t imagine it’s not possible to add some flexibility/options to the midi routing.

Sorry, I think I understood, maybe you didn’t understand me. I’m not saying it’s satisfying. Just saying it’s technically possible with Thru and Out merging.

Like?
It sends what comes in, hence it can send your external keyboard notes to another synth.

I’m really happy with those updates, but I think the actual midi sequencing functionalities are pretty ridiculous! I usually don’t wait for updates from facturers to find midi workarounds.
I already have a ticket for AR, next for A4.
Btw I’m enjoying A4 a lot with my external 88 keys keyboard those days! :content:

1 Like

Midi thru takes whatever data is received at the input and echoes it back out. Midi out only transmits data from that particular machine.

Google says…
MIDI thru port provides a copy of the MIDI signal arriving at a corresponding MIDI in port.

I don’t understand the problem.

ANALOG KEYS only: OSC1 makes a sound when triggered and set to GND / INL / IN R.

I found this behaviour on firmware 1.35, and and was hoping for a fix with the latest FW release. As I still can reproduce it with FW 1.40, I just wanted to document it somewhere and hope this is the right place.
Elektron’s support has confirmed the behaviour, it seems to be hardware related (“PCB crosstalk”) and is coming from the oscillator, not from the filters or overdrive. It might get fixed with a future firmware update, but there is no date yet. A4 mkI / mkII are not affected.

What’s happening?
If you want to route external audio through the AK’s filters (manual page 72) you need to trigger and open the AMP envelope of the track you want to route your audio through. This results in a rather weak but constant sound coming from OSC 1 of the used track. It seems that OSC 1 is not really off or grounded but gets triggered by the keyboard or the sequencer. And this signal somehow gets to the audio path, together with the external audio. This behaviour is identical for all four audio tracks, but only on OSC1, OSC 2 is not affected.

If you want to reproduce this:

  • initialize a new project
  • set all 8 OSCs to GND (or IN L or IN R)
  • set all 8 OSC LEVs to 0 (or else, this setting has no effect on the behaviour)
  • set all AMP VOLs to 127
  • MASTER VOLUME to full
  • play the keyboard: you will now hear the melody you play. The sound tracks the keyboard perfectly and is velocity sensitive. The effect can be heard better with higher notes.

Or just follow the manual page 72 without any external source connected.

My workaround for now:
OSC2 is not affected, so I route external (mono) audio through there. In addition, I set OSC1’s waveform to TRI with an OSC LEV = 0. At least for me, this works sufficiently. I believe the “softer” waveform makes it less noticeable.

I found this really illogical as well. On the lookout for Keys now. I assume the keyboard there functions like one would expect, just like the mini keys on the A4 do.

Yes, like the A4 mini keys do, you’ll be fine ( I imagine) - I don’t see this as expecting MIDI workarounds or so on, I see it as failing to see through the full extension of the Auto Channel idea. Perhaps there are limits to what you can expect that won’t take time to deliver, but it is a gap in functionality which one would reasonably not anticipate

Track Monitoring whilst FX tweaking when using MIDI is not working

Traditionally you can play e.g. Track 1 and then tweak the FX settings or levels. When you select the FX track to do so, it keeps the last track half-lit to retain focus, thus allowing auditioning whilst playing. A second tap of FX track will give that track total focus

Now, if you do so whilst using the MIDI out, the MIDI is not played, only the internal track

Seems inconsistent and it’s not as helpful, probably overlooked, but would be good if the same ability was enabled - especially as there’s a good reason to be tweaking FX sends for the synth coming into the inputs

Ticketed as omission/bug

2 Likes

here, externally sent notes from the 4 tracks are still received when adjusting the fx track params (in the halfway, part-fx mode you mention) – but the AK encoders are sending out control data too. could that be the prob? maybe the encoders are sending unwanted controller info to your external kit, muting or lowering its volume??

I am talking only about live playing. This is broken in the same way that external midi playing doesn’t work. It seems like it was overlooked as a new use case w MIDI

Not simple. What if you want live playing with FX track? I think they have to rethink all this.

Things annoying me : if you’re in Grid Rec, select FX or CV track, Grid Rec is off. Why?
I’d like to select directly Fx or CV like other tracks, but you’d need another way to select Fx parameters and keeping 1 of 1-4 tracks active…:thinking:

If I want to play Multi Map with FX or CV tracks and midi loopback, I have to select tracks 1-4 to hear Multi Map. So I can’t record / play Multi Map live with FX / CV track and monitoring.
Multi Map should be heard with any selected track.

2 Likes

I reported that one too, it makes copy paste between tracks annoying

1 Like

Presumably that works fine though, when FX track is double pressed to focus it. That seemed to work just fine tbh iirc. I am highlighting deviations from normal workflow when you consider MIDI as the primary source dest.

1 Like

More strange behaviour with conditions and track scales. Example:

Pattern 1, Track 1: Page mode Advanced, 64/64 2x speed, master length 64, master tempo 1x
Pattern 2, Track 1: Page mode Advanced, 16/16 1x speed, master length 64, master tempo 1x

All A:B Conditional locks on Pattern 2, Track 1 following on from Pattern 1 without stopping occur a bar early.

But if I change Pattern 1’s master tempo to 2x and master length to 128 so it plays exactly the same, the conditional locks on pattern 2 work as they should.

Anyone else come across this and is it a bug or am I missing something?

1 Like

I can confirm that what you observe is true. I see the same behaviour using simple test case of 1:2 - it plays fine on Pattern 1 and Pattern 2 when they are played individually, but as soon as they are chained, there is this anomaly whereby the first pass of pattern 2 is not serving up the 1:2 it plays on the second pass

It certainly feels like a bug, there’s a bit of a discussion somewhere relating to TRC strangeness following Track scale introduction

To remedy/illustrate the issue, if you change Pattern 1 to 1x it will play normally in a chain.

There’s something about the way that TRCs are accounted for that is sensitive to Scale and Master too - but irrespective, this feels like it’s undesirable, especially if there’s no way to rationalise this and predict what will happen

You should report this as a bug IMHO (please say if you do and please feedback the general response)

1 Like

Hi. Thanks - I’ll report this now.

2 Likes

10 posts were merged into an existing topic: Analog Four/Keys OS 1.40A: bug reports

New discussion (OS 1.40A):