Ableton + Overbridge midi channel problem

Morning all. I’m experimenting with workflow with Ableton and my DN. I’m trying to use my QWERTY keyboard as a MIDI keyboard and it works fine but I can only trigger track 1 of my DN. Using the QWERTY input in Ableton seems to only trigger MIDI channel 1, so I changed settings in the DN so that the “Auto” channel is 1, but it doesn’t matter which track I select on the DN, the keyboard only triggers track 1.

Any thought/suggestions? Overbridge works very well to multi-track the DN when it’s playing back and I’m really pleased with this but I’d love to be able to “play” the currently selected track of the DN from my QWERTY keyboard until I get a proper keyboard (if ever).


1 Like

Turn auto channel off. Set up 4 midi tracks and set their channels corresponding to the 4 channels of the DN. Then you only need to arm the channel you want to play in Ableton.

Cheers. Sounds like it should work but it kind of defeats the purpose of a quick and easy way to preview/play sounds without having to switch tracks and arm each one - I was hoping to just switch track on the DN and play with the qwerty keyboard. It also chews up 4 tracks in Ableton. It’s a good start though so thanks anyway. Perhaps I’ll just shell out for a keyboard or a pad controller that can send on different midi channels.

I’m trying to keep super minimal and I’ve already had an idea of how to use the DN as a midi control surface in Ableton for launching scenes and controlling volume/pan/sends etc.

I’ll give it a try later, thanks!

Did you ever solve this? I’m having the exact same issue.

Midi on CH8 is going into my DAW and ‘Track 4 Channel’ is also set to 8 on the Digitone but I get no sound. If I force the Midi to Channel 1 in my DAW then I get sound, on that Channel only.

Auto is OFF and the other Midi Channels are also OFF (though I tried matching them as per comment above but this didn’t fix anything).

Basically, Digitone only responds to Midi Channel 1 which in turn only plays Track 1 on the Digitone.


(I forgot to CC you in the comment above so you would be notified)

The plugin is track 1,
you must set up different midi tracks for track 2,3,4 for the digitone if you want to do it the proper way…

Or you can set up an external instrument track and send it to the auto channel,
I’ve actually set up an instrument rack and put the external instrument in the same channel and blocked midi notes going to the plugin using a max for live device…

So it is possible to do if you are good with ableton…
I have all my audio tracks separated on the same channel and also it’s the auto channel for my external sequencing template…
but it’s not really designed to work like that when sequencing from inside Ableton

I did have another Midi Track pointing to another Track on the Digitone but the DN wouldn’t respond.

I’ll give it another try. Thanks for the detailed tips!

OK thanks for the help y’all. I got it working, in Bitwig I have:

  • 1x VST track (for audio playback)
  • 4x Midi tracks with a HW Instrument. In the Midi Track info panel I have Channel settings as “From:All To:Same”

Then my Midi (which is coming from a NDLR) is set to send on Midi Channels 5/6/7/8 and the DN is set to receive Midi on the same channels.


1 Like

i’m in ableton

My workaround:

1 midi track for the overbridge device (ex: digitone plugin) - set the midi to off so that it’s not receiving midi notes

1 midi track for the external instrument - set the midi within the external instrument to your device & then to your auto channel channel - set the midi to in so that it is receiving midi notes

also, i don’t know what the defaults are, but my syntakt did not work at first (only my digitone & digitakt did), but then i realized that my preferences>link midi>midi port settings were different on my syntakt than the other two, so then i changed the output: elektron syntakt settings to on for “track” and “sync”

sorry if i’m not explaining this well