A4 Program change/Pattern Change with Maschine

I just spent HOURS trying to get this to work. Read the manual, watched videos, scoured the forum, still not working. I saw a lot of great advice for Ableton users, but I’m doing my production in Maschine (then dump to Pro Tools)

I can get Maschine to send Program message ( I have the AUTO MIDI channel set to 16 and PC set to AUTO). However, it won’t change when I have the PC note set at the beginning of a Pattern(Maschine Pattern). It needs an 1/8 note heads up to change to the next pattern. That doesn’t really work when changing patterns in Maschine, basically, I have to wait a full length of the A4 pattern for it to change.

I have changed all Pattern Jump Settings, MIDI clock offset in Maschine (it goes max 200ms).

I tried the Multi Map feature to use MIDI notes, but I can’t get that to work at all besides using the onboard keyboard while the sequence is running autonomously.

I REALLY like the A4, but if I can’t get it to work with Maschine, it’s kind of useless to me except for tinkering with and sampling in, which is about 1/8th of my workflow.

Has anyone found a magic recipe of settings to get this to work? Or any advice on the multi map feature?

Thanks

Have you set up the PERF CHANNEL in the midi config of the A4 correctly?

Using the multi map is the only way to get “just in time” pattern changes working. PC messages will not work “just in time” on any Elektron device, but needs to be sent ahead of time.

1 Like

I haven’t touched the PERF controls

Is that somehow tied to the MultiMap?
I can’t find that in the manual, what am I missing?

Thanks!

Actually, I just saw it in the manual after all. It was like a “caption” I overlooked

So, multimap responds to whatever channel the PERF midi channel is set to?

I suppose that makes sense, I can also use that same pattern in Maschine to control CCs through the PERF controllers.

I’ll try it tomorrow. I’m tired, lol

Thanks for your help!

Yes. Since the multimap works with MIDI notes it requires a separate channel which doesn’t interfere with the auto channel or the track channels.

1 Like

thanks a lot man, that works great

There’s so many unconventional things about this box, I’m still wrapping my head around some of the “concepts”

Appreciate the help, this forum is great!